ESP8266 - Hardware serial - Please Help!

Hello guys, I’m using the Arduino Nano with ESP8266 with blynk. The fisrt step was upload the Software Serial example with my Arduino Nano, and I got the following response OK.

[19] Blynk v0.3.3-beta
[520] Connecting to iPhone de Renato
[5754] IP: +CIFSR:STAIP,“”

[5801] Connected to WiFi
[140060] Ready (ping: 75ms).

Great! After that, I’ve tried to upload the HardwareSerial example, which I read that it’s more stable and everything with the same circuit connection, just changing the TX/RX pins that were in pins 2(tx) and 3 (rx), now they are TX at Arduino RX, and RX at Arduino TX. But now I’ve got the following response:

[19] Blynk v0.3.3-beta
[520] Connecting to iPhone de Renato
[1531] Failed to disable Echo

Please, does anybody know how to fix it? I’ve been trying to read everything about it and I couldn’t solve it, I have no idea what is wrong. Can anybody tell me how to run the hardwareSerial example code to implement my Blynk APP?

Thanks a lot guys

What esp8266 firmware are you using?

I’m using the AT version @nolmath

AT version: 20 2015 10:04:26)
SDK version:1.0.0

please, @Lichtsignaal @Costas any idea?

How do you get the debug information? On the Nano you have to use the SoftwareSerial for debug/console output if you have the ESP wired to the hardware serial port.

Also, are the Baud settings good for the ESP with the Hardware Nano port?

Thanks for your reply. The ESP is connected at pins RX/TX of Nano, do I have to change any connection for the Hardware Serial?

I’ve also changed the baud rate for my ESP wiith the CIOBAUD command if I’m not wrong.

Hi @RenatoLacerda
I always use hardware serial with my nanos or pro-micros, this is the set up I use:

Is your sketch like this one?

1 Like

CIOBAUD is correct command indeed.

@psoro drawing is what I use to, more or less. So I can highly recommend you follow that.

As far as for hardware serial sketch, you don’t need to change anything, except maybe the Baud to match of course. You can also add SoftwareSerial on two other pins for debug output if you wish, that might be handy doing the troubleshooting. But you will need a USB-to-Serial convertor for that on your PC.

@psoro @Lichtsignaal
Hi guys, thank you very much for your tips, it helped a lot… I’ve tested the exactly circuit as you showed in Arduino Nano, but it still have the same error “Failed to disable echo”,

But now, I’ve uploaded in my Arduino Uno, and it has showed no error, and connected to my wifi network, using the HardwareSerial example, but it is still a problem, my APP cannot connect to the Hardware, the APP shows the message “Arduino Uno is offline”. I’ve changed the auth token as well as the wifi information. In the monitor serial it shows

Does anybody have any idea? I’m excited because I’m almost there. Thank you again

have you checked:

Yes @Pavel thanks for your reply. The software Serial works fine, just the Hardware doesn’t. Both also compile well

So, does this debug output come from a USB to serial attached to your PC? Because the IDE seems to detect the UNO which will not happen with that.

Or it could be a bad connection to your Wifi Accesspoint. Have you tried a telnet to on port 8442? Could also be a firewall issue on your router and/or ISP (Internet or mobile).