BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Esp8266 does not connect to local server

esp8266
#1

Local server on RPI2
Module NodeMCU v3
Sketch arduino ide
The module does not connect to the server, instead it breaks into the Internet.
Arduino writes: Connecting to blynk-cloud.com:80 messages are repeated.
I tried with different ports 8080, 9442.9443.
I found a similar problem, but it is not clear where to replace the address with my own ( (SOLVED) Connect to local blynk server on raspberry) .
please, help
here’s a sketch:

//My GitHub https://github.com/manoranjan2050
//My Hackster.io https://www.hackster.io/Manoranjan2050
//This Video Link https://youtu.be/0dbws1i2GoE
#define BLYNK_PRINT Serial
 
 
#include <ESP8266WiFi.h>
#include <BlynkSimpleEsp8266.h>
#include <DHT.h>
 
// You should get Auth Token in the Blynk App.
// Go to the Project Settings (nut icon).
char auth[] = "4258890441574e08b7dde8ec975730b3";
 
// Your WiFi credentials.
// Set password to "" for open networks.
char ssid[] = "TU";
char pass[] = "sdf";
char server[] = "192.168.1.38";  // The local IP address of your Local Server device.
 
#define DHTPIN 2          // D2
 
// Uncomment whatever type you're using!
#define DHTTYPE DHT11     // DHT 11
//#define DHTTYPE DHT22   // DHT 22, AM2302, AM2321
//#define DHTTYPE DHT21   // DHT 21, AM2301
 
DHT dht(DHTPIN, DHTTYPE);
BlynkTimer timer;
 
// This function sends Arduino's up time every second to Virtual Pin (5).
// In the app, Widget's reading frequency should be set to PUSH. This means
// that you define how often to send data to Blynk App.
void sendSensor()
{
  float h = dht.readHumidity();
  float t = dht.readTemperature(); // or dht.readTemperature(true) for Fahrenheit
 
  if (isnan(h) || isnan(t)) {
    Serial.println("Failed to read from DHT sensor!");
    return;
  }
  // You can send any value at any time.
  // Please don't send more that 10 values per second.
  Blynk.virtualWrite(V1, t);
  Blynk.virtualWrite(V2, h);
}
 
void setup()
{
  // Debug console
  Serial.begin(9600);
 
  Blynk.begin(auth, ssid, pass);
  // You can also specify server:
  //Blynk.begin(auth, ssid, pass, 192,168,1,38, 9442);
Blynk.begin(auth, ssid, pass, server, 9443);
 
  dht.begin();
 
  // Setup a function to be called every second
  timer.setInterval(1000L, sendSensor);
}
 
void loop()
{
  Blynk.run();
  timer.run();
}```
0 Likes

#2

You have two Blynk.begin statements. The first needs to be commented-out, as it’s connecting to the cloud server.

Pete.

1 Like

#3

// Blynk.begin(auth, ssid, pass, "blynk-cloud.com", 80);
did not help :frowning:

0 Likes

#4

It wouldn’t. This line is trying to connect to the cloud server:

This is the line you need to enable:

but I’m not sure about the port number.

Pete.

1 Like

#5

The port number should be 8080 for local server.

3 Likes

#6

The correct port is 8080… 9443 is for the App.

2 Likes

#7

Just noticed that the IP address of your local server is in the wrong format, so won’t work.

It either needs to be in quotes with decimal points instead of commas, or declared as an IPAddress variable type if you’re using commas.
However, you’ve already declared a variable called ‘server’ with the IP address in the correct format…

So the connection string should be like this:

Blynk.begin(auth, ssid, pass, server, 8080);

Pete.

2 Likes

#8

a minor mistake didn’t make it all today.
a whole day of experiments :slight_smile:
Thank you all so much!
It’s alive! LIVE !!!

1 Like