ESP8266 crashes after a few seconds

Hey there,
I’m having issues with my esp8266(01) and my Wemos D1 board.
I downloaded the latest library from gitub (0.5.0) and installed it in the arduino ide.
Then I copied the example sketch for the esp8266 from the blynk code generator and pasted it in the arduino ide. After pasting my ssid, password and auth token, I uploaded the sketch. I didn’t change the example sketch furthermore. The esp8266 connects to the blynk Server succesfully, but “crashes” after that and disconnects.
This goes on and on…
Output from the UART:

    A⸮⸮⸮=⸮⸮⸮[62] Connecting to (myssid)
    [4563] Connected to WiFi
    [4563] IP:
     ___  __          __
   / _ )/ /_ _____  / /__
  / _  / / // / _ \/  '_/
 /____/_/\_, /_//_/_/\_\
        /___/ v0.5.0 on Arduino

[4635] Connecting to
[9635] Connecting to
[9654] <[02|00|01|00] (myauthtoken)
[9673] >[00|00|01|00|C8]
[9673] Ready (ping: 18ms).
[9673] Free RAM: 42928
[9687] >[14|00|01|00|08]
[9714] >pm[00]6[00]out
⸮⸮X⸮⸮⸮[65] Connecting to (myssid)
[569] Connected to WiFi
[569] IP:
    ___  __          __
   / _ )/ /_ _____  / /__
  / _  / / // / _ \/  '_/
 /____/_/\_, /_//_/_/\_\
        /___/ v0.5.0 on Arduino

[637] Connecting to
[5638] Connecting to
[5656] <[02|00|01|00] (myauthtoken)
[5681] >[00|00|01|00|C8]
[5681] Ready (ping: 25ms).
[5681] Free RAM: 42928
[5690] >[14|00|01|00|08]
[5717] >pm[00]6[00]out
⸮⸮Q(⸮⸮r⸮⸮[65] Connecting to (myssid)
[569] Connected to WiFi
[569] IP:

To check wether my hardware is faulty, I uploaded the Advancedwebserver example sketch from the esp8266 library Sketch
and the esp8266 connected successfully to my router and the connection is very stable.

Arduino IDE: 1.8.3
Blynk lib: 0.5.0
Board settings: Generic ESP8266 Module / Wemos D1
Used Boards: ESP8266-01 and Wemos D1

Which one are you actively working with?

Which sketch… there are a few :wink:

I’m currently working with the esp8266-01 module, but I also tried it my Wemos D1 board. I think they have the same issue.
The esp8266-01 module is on a breadboard hooked to my bench power supply at 3,3V. I added some caps (100nF 10nF and 2,2µF) in parallel to stabilize the voltage.
This is the sketch I have used:

/* Comment this out to disable prints and save space */
#define BLYNK_PRINT Serial

#include <ESP8266WiFi.h>
#include <BlynkSimpleEsp8266.h>

// You should get Auth Token in the Blynk App.
// Go to the Project Settings (nut icon).
char auth[] = "YourAuthToken";

// Your WiFi credentials.
// Set password to "" for open networks.
char ssid[] = "YourNetworkName";
char pass[] = "YourPassword";

void setup()
  // Debug console

  Blynk.begin(auth, ssid, pass);
  // You can also specify server:
  //Blynk.begin(auth, ssid, pass, "", 8442);
  //Blynk.begin(auth, ssid, pass, IPAddress(192,168,1,100), 8442);

void loop()
  // You can inject your own code or combine it with other sketches.
  // Check other examples on how to communicate with Blynk. Remember
  // to avoid delay() function!

Let’s concentrate on the Wemos D1… less unknown factors :wink:

Well, maybe… is that the old Arduino shaped D1 or the newer D1 Mini?

1 Like

It is the old Wemos D1 in the arduino uno form factor.
But I downgraded the blynk library to 0.4.4 and now it is working on my Wemos D1 and the breadboard Esp8266-01, weird.

1 Like

Not entirely… I have found up to 0.4.8 very stable, but 0.5.0 has some unique features that seem to both help and hinder :thinking: Perhaps try the next version when it comes out.

So, is this issue considered solved?

In Arduino IDE go to [Tools] -> [IwIP Variant] and select [v1.4 prebuild]

1 Like

@bilbobg Interesting… I have never had significant issues with the default v2 Prebuilt (MSS=536)… Well, that I know of :stuck_out_tongue_winking_eye:

Is this a older D1 (UNO style) issue?

No it’s an ESP8266 core issue.

1 Like

Well, a little Googling later… and I am still bewildered :blush: But I guess since I haven’t had any notable crashes with my ESP’s… I will tiptoe away and hope it doesn’t find me :slight_smile:

no ineed help

I could not find this

OK, solved.

@Ashraf_Moner Please create your own topic with details as to your exact issue. Thanks