ESP8266 connection issues with Arduino core 2.5.0 beta2

I just wanted to let you know that there are some issues between Blynk and the Arduino core libraries for ESP8266 v.2.5.0 beta 2.

During the past few days I’ve been having wild problems with a NodeMCU that couldn’t connect to my local server. It kept trying to connect and timeout.
I am using local server on a Raspberry PI 3b+. The Raspberry is connected over ethernet to the router.

When I switched to using the core libraries 2.5.0 beta1 everything started to work.

So, I was testing the simplest of sketches, one taken from the examples

#define BLYNK_PRINT Serial

#include <ESP8266WiFi.h>
#include <BlynkSimpleEsp8266.h>

char auth[] = "myAuthToken";
char ssid[] = "mySSID";
char pass[] = "myPassword";

void setup()

  Serial.println("before Blynk.begin()");
  Blynk.begin(auth, ssid, pass, IPAddress(192,168,1,86), 8080);
  Serial.println("After Blynk.begin()");

void loop()

and what I see in the debug console is:

before Blynk.begin()
Connecting to mySSID
[27667] Connected to WiFi
[27667] IP:
    ___  __          __
   / _ )/ /_ _____  / /__
  / _  / / // / _ \/  '_/
 /____/_/\_, /_//_/_/\_\
        /___/ v0.5.4 on NodeMCU

[27745] Connecting to
[27803] <[02|00|01|00] myAuthToken
[30844] Login timeout
[32844] Connecting to
[32852] <[02|00|01|00] myAuthToken
[35855] Login timeout
[37855] Connecting to
[37864] <[02|00|01|00] myAuthToken
[40866] Login timeout
[42866] Connecting to
[42872] <[02|00|01|00] myAuthToken
[47874] Connecting to
[47879] <[02|00|01|00] myAuthToken
[50881] Login timeout
[52881] Connecting to
[52886] <[02|00|01|00] myAuthToken
[57889] Connecting to

and this goes on forever.
As you can see, it doesn’t even come out from the Blynk.begin() function.
I have tried to increase the timeout intervals, but nothing changes.

I have spent a lot of time troubleshooting my network and tried another router as well.
The only interesting thing that I can tell you is that I have been pinging the ESP8266 from the server. Whenever the ESP8266 prints the myAuthToken on the serial log, it stops responding to pings. And when it says “Login timeout” or “Connecting to…” it starts responding to pings again.
It looks as if the WiFi code freezes for some time.

So, besides your “wildly descriptive” explanation… :lion: :tiger: :bear::open_mouth:… Do you have any further details that might help the developers narrow down what/if changes needed with Blynk or espressif?

You are right and I am sorry.
I added some details to my post above.

OK, unless you are literally editing all of that Serial monitor output before posting here :crazy_face: … your AUTH token is NOT supposed to be the actual words “myAuthToken:stuck_out_tongue_closed_eyes: But the real AUTH generated by your Server and provided via email and in your App when you add a device to your project.

1 Like

@nedoMD 2.5.0 beta2 has very few bugs. An issue was found with IPv6 addresses and the master branch now has the fix, but that’s not your problem.

Oh, yes. I have edited my token before posting on this forum.
As I said, as soon as I switch to the older Arduino core libraries everything works as expected. And this is why I thought that there might be a malfunction between blynk and the new ESP8266 libraries for arduino.
Apart from Blynk, other projects do work with the new arduino libraries. I have uploaded and tested some other non-blynk sketches and they all work.

I’m interested in seeing if there will be other people complaining about the same issue. And if in the end it will turn out that I’m the only one I’ll start suspecting that my nodeMCU is faulty (unfortunately I now have only one module available, otherwise I would have run some tests on other modules).

I would guess you have the wrong token or a problem with your server. Try Blynk’s server.