ESP8266-1 standalone will not connect to Blynk

Hi all, new user here to Blynk and ESP. I am trying to connect a new esp8266-1 to my blynk account, but it says offline. I have tried the quickstart, and have made a new template and tried that with no success. (the upload of both were successful with no errors) I have uploaded a blink sketch to flash a LED to the device with Arduino Ide and it works, so I can communicate with it. I am using a windows 7 computer and the current Blynk console. I also connected the module to a Uno and I can send AT commands thru the serial monitor (I sent the AT command to get WiFi nodes, and it returned the ones that are available in my home.

Any idea what I am missing?


If you’ve successfully uploaded a sketch to the ESP-01 then it will no longer respond to AT commands, as the AT firmware will have been overwritten by the sketch.

When you used the Edgent sketch, what board type did you un—comment in the sketch?
The ESP-01 has limited available GPIOs , so it’s difficult to use with Edgent. More reading here…


I did not un-comment anything, I followed the procedure in the quickstart, copied the three lines to the new sketch and uploaded it. I configured the board type in the IDE menu. I do not know what the Edgent item you reference is.

Please post the sketch that you uploaded to the device.


#define BLYNK_DEVICE_NAME "Jeff"
#define BLYNK_AUTH_TOKEN "vxze0aPVDxKv1B4QAnN9aVEJGUw904aX"
void setup() {
  // put your setup code here, to run once:


void loop() {
  // put your main code here, to run repeatedly:


Well that won’t do anything.

You haven’t included any Blynk libraries, provided any WiFi credentials or included any Blynk connection or commands.

I’d suggest that you go back to the Quickstart option in the web dashboard and this time click the “Copy Code” button and paste that into your Arduino IDE (after you’ve filled-in the WiFi credentials on the left hand side of course)…


Thank you so much for the help, I had the esp connected with usb, so I chose that as the connection type, It never showed me the wifi options, I changed the connection type in the quickstart, imputed the info, uploaded and viola… it was connected!

Now to understand how it all works and create something

1 Like