Esp32 cam not working! No wifi connection

Good afternoon, i have a trouble with my esp32 cam(esp32s).

It can’t connect to my wifi network.

The strangest thing is, that if i share my wifi connection from my phone everything works fine, and esp connects with out any problem. And it doesn’t matter if my phone has mobile internet or wifi connection.

I have also written settings for static ip, 2 day ago wifi was connecting, but from yesterday started my problem.

I’m using blynk empty example and wifi.h library.

Thanks for your advises.

What exactly does this mean?

Have you tried rebooting your router and any WiFi repeaters on your network.
What does your serial monitor say?


I have written static ip for esp32s. I didn’t reboot any router in my house, but esp8266 and all my gadgets connects normally.

Does this mean that you’ve specified a static IP address in your sketch, assigned a static IP address in your router or something else.
Simply repeating the same words when asked to clarify EXACTLY what they mean doesn’t help.

Then you should do that before doing anything else.


Static ip in my sketch. I changed nothing in my router.

Well, once you’ve rebooted your router and tested again, if the problem still persisted please post your sketch.
Redact your WiFi credentials and Auth code, but leave your static IP unchanged.
You should also provide details of the IP address range that your router is using for DHCP, and the internal IP address of your router.

When you post your code, ensure that you put triple backticks at the beginning and end of your code, so that it displays correctly.
Triple backticks look like this:

Unformatted code will be removed, so use the correct backticks characters (copy and paste from above if necessary).


Thank you, i will try to do this, and reply as soon as possible)

#define BLYNK_PRINT Serial

#include <WiFi.h>
#include <WiFiClient.h>
#include <BlynkSimpleEsp32.h>

// You should get Auth Token in the Blynk App.
// Go to the Project Settings (nut icon).
char auth[] = "";

// Your WiFi credentials.
// Set password to "" for open networks.
char ssid[] = "";
char pass[] = "";

void setup()
  // Debug console

WiFi.config(IPAddress(192,168,1,145), IPAddress(192,168,1,1), IPAddress(255,255,255,0));



void loop()

The DHCP range is: 1-250

I assume your router is at (a piece of info I asked for, but which you didn’t supply).

If that’s the case then this shouldn’t be true…

Personally, I always specify at least one DNS server on my WiFi.config string, and change my DHCP range so that my static IPs are outside of my DHCP pool to avoid potential conflicts.


That’s not how I would setup a static IP :thinking:

I use this format (with my own IP ranges) without any issues…

char ssid[] = "xxxxx";
char pass[] = "xxxxx";
IPAddress local_ip(192, 168, 1, xxx);  // Pick the IP for this device
IPAddress gateway(192, 168, 1, 1);
IPAddress subnet(255, 255, 255, 0);
IPAddress primaryDNS(192, 168, 1, 1);

void setup() {

WiFi.config(local_ip, gateway, subnet, primaryDNS);
WiFi.begin(ssid, pass);

// and so on...
1 Like

Yes, I’m sorry: it 2-254.

And the gateway is

I have already tried this sketch, but no results.

Then I suspect your issue has nothing to do with Blynk… as the WiFi connection setup I showed also has nothing to do with Blynk (but can be used with it) and woirks fine for my three ESP32Cam boards (while treating them like basic ESP32’s that is… I haven’t bothered with customising Blynk and webcam options together on that board, yet.)

Perhaps you have other networking issues?

OK thanks, i think something wrong with my ep32cam(I think it’s fake).
I have also esp8266(i will do my project with it).
thank you)

Fake? It is an open source design as far as I understand.

I am guessing you do know how to upload to it… as in needing a FTDI adapter and wiring in the Flash Mode button?

Yes sure, I have Arduino mega, a have FTDI, and i know how to do flash mode.

OK… Have you tried loading in a basic example sketch, no WiFi, but perhaps somthing that just flashes the built in LED?

Yes it’s work

i have connected 7 digit display

Not bad… considering the lack of usable pins :slight_smile:

Well, as you have found out, that board is a bit finicky. While I have the Static IP working, I am still troubleshooting getting functional OTA on it.

So, yup, unless you really, really, need the camera… use a different board.

1 Like