ESP is not responding. HELP

Which pins on your Mega is the ESP-01 connected to?

This baud rate setting has to match the baud rate that your ESP-01 is expecting.
Therefore this either has to be the default baud rate setting for your module, or you need to have changed the ESP-01’s default baud rate via an AT command.


1 Like

Thanks for the feedback I’ll try changing the baud rate via the AT command.

Or, you could just change your sketch to match the baud rate of your ESP.


Just tried both, Still the same issue. I’ve already changed the baud rate of the ESP-01 and I’m able to get my IP address using the AT command but it’s still not responding when I upload my general code.

Many issues with connecting an ESP-01 to an Arduino… and solutions already posted for them all over the place in this forum :slight_smile: Search for keywords like ESP-01 and Mega :stuck_out_tongue:

Usual suspects are not powering the ESP-01 from its own 3.3v source (do not do so from the Arduino), not sharing the GND between power sources and not crossing the signal wires, TX to RX and vice versa

I don’t understand this comment.

Have you uploaded any code to the ESP-01, or is it still as it came out of the packet?

Try answering my original question about wiring…


this is the format of my connection:


Yes, I have uploaded codes to the Esp-01.

You say Mega, then show us a hookup list to an UNO with totally different settings and pinouts than your sketch has… I think you need to clarify… and search more :stuck_out_tongue:

I will leave this topic alone now, as I have already answered all ESP-01 to Arduino questions many times before in this forum.

1 Like

Then that’s one of your problems.
The ESP-01 needs to be running AT firmware, and uploading a sketch to it overwrites that firmware. You need to re-install the AT firmware (which can’t be done via the Arduino IDE).
This might help you in that quest:

Your other problems are to do with this:

Your Arduino sketch says that you’ll be using Serial1 to communicate with your ESP-01…

Yet you’re connecting the ESP to Serial instead.
Serial1 on the Mega are pins 19 (Rx) and 18 (Tx).
In addition, the Tx on one device needs to connect to the Rx on the other and vice-versa, so it should look like this:

ESP-01 Tx ——> Mega pin 19
ESP-01 Rx ——> Mega pin 18



Your Serial Monitor shows you are using Arduino Mega . . . But your table shows Arduino Uno . . . not the same pins . . .

Also . . .

If you have uploaded code to the ESP01 you have overwritten the AT firmware, it will not communicate with the UNO or MEGA . . .

As a test I used your sketch, with Arduino MEGA, with ESP-01 AT Firmware at 9600bd (I flash my ESP-01s to 9600bd as they are much more reliable at low speed) - strangely it would not work connected to Serial1 (Pins 18, 19) - but worked perfectly fine on Serial2 (pins 16, 17).

So your sketch is fine if you change to Serial2 - but you need to clarify if you have AT firmware or have overwritten it with custom code.

good luck


Worked out why Serial1 did not work . . . the printing on the Mega board is reversed for RX1 and TX1, reversed the connection and it works fine . . .


1 Like

Alright, will give it a try today, getting a new Esp-01 module. I accidentally connected the one I had the 5v port. I think the circuit got fried and it’s not responding anymore. I’ll keep you posted on my progress once the new module arrives.

Alright, thanks a lot for this info. I’ll try this and give you feedback once I get my new Esp-01 module.

@PeteKnight @Bill_Donnelly I have a questio though, do I really need to flash an Esp-01 if I just got it?
I tried flashing my old Esp-01 module but it didn’t work. but from my Arduino serial monitor I was able to connect to the wifi on my phone.

No… not if you are using it as a WiFi interface for something else like an Arduino. Generally one only needs to reflash an ESP-01 with Arduino IDE/code if they want to use it as a standalone “mini” ESP8266 board.

Reflashing an ESP-01 back to the default AT firmware is usually done with seperate “firmware flashing” software… it has been awhile since I bothered with that, so you may need to Google for that yourself.


No, it should come flashed with the AT firmware - we only mentioned flashing because you said in your earlier post that you had

This implies you had overwritten the AT firmware on the ESP-01 with your own, but if you didn’t, then no need to re-flash with AT firmware.


1 Like

Thank you!!


@PeteKnight , @Bill_Donnelly and @GTT thanks so much!!! Everything is working fine now. I really appreciate the help.