ESP is not responding (but if...)


Hi all,

I used an esp01 module with the mega arduino following your guide: “” . Everything works perfectly until I disconnect the power supply and then reconnect it.

  • If I feed the mega arduino and the module esp01 at the same time I receive the message: “ESP is not responding”
  • If you feed the mdu arduino first and then the esp01 module works !!!

Any clues?
Thank you in advance

You could try tying the resets together. And the ESP needs it’s own 3.3v PSU as the regulator on the Mega is not strong enough.

The ESP was powered with it’s own power supply. I tried tying the resets together but it has the same behavior.
I’ll try to understand why… if you have any other suggestion please let me know.
Thanks for your help.


Shared GND? It needs it.

Otherwise I do not know. I run a Mega/ESP-01 combo and they both power up together.

Powering the ESP-01 first, then the Mega works fine.

But if I power the Mega first, then obviously it gives the error as the ESP-01 is not powered, as is needed in order to respond :stuck_out_tongue: But I have a auto re-connection routine that handles that anyhow and thus it will work as soon as the ESP-01 is powered up.

I think it’s a hardware problem. When I power everything the voltage between RX and GND is 2 Volt?
I don’t know why and I’m struggling to understand why. If u have any idea please let me know.
I’m going to try with another esp01 and see if it’s somehow dameged.

Pay attention to the gnd question… Are all of the gnds the same?

Don’t try to check voltages when the hardware is working… You’ll get weird values.

Ok. I’ll check again to make sure everything is connected properly.

it was indeed a ground issue. Thanks guys for all the support you gave me.