ESP 8266 StandAlone No Such File Error

I’ve searched the forum for about a half hour, I’ve read and followed every instruction in the sketch, updated IDE, updated Blynk only added my particulars to the example sketch, selected the correct board in Tools, COM port is correct, I’ve tried both 9600 as well as 115200 bauds and merely wish to upload an run the ESP8266 Stand Alone Manual IP sketch just to verify that my Adafruit Huzzah Feather (ESP8266) board can connect to wifi and subsequently Blynk server. I currently have an Arduino Ethernet project running with Blynk since Jan 1 2017 (13 months) and am looking to divide that project up into several smaller ESP connections. It seems no matter what I do I get the error of No Such File Or Directory regarding #include <BlynkSimpleEsp8266.h>. I’ve even tried to change < > to " ". As previously stated, I only added my basic particular info; auth/ssid/pass/IP info and the sketch will not compile. Can anybody think of what else I need to try?

Edit - I forgot to mention I also tried “copying” the .h files into the example directory in the event there were location conflicts or similar, so that’s why you see added tabs.


Sounds like you need to completely clean out the old Blynk Library folders and manually reinstall the latest Blynk Library as directed here… Releases · blynkkk/blynk-library · GitHub

1 Like

By manually reinstall, do you mean something other than deleting the previous Blynk library from Documents/Arduino/Libraries and extracting the new Blynk library to the same location? That’s what I just did and the example gave me the same error. FYI, I’m using IDE 1.8.4.

The folders in the Blynk libraries should go in your libraries folder /Arduino/libraries/ not in /Arduino/libraries/Blynk/

The folders in the Blynk tools should go in /Arduino/tools/.

1 Like

Thanks Costas, that did the trick. If I may, I’d like to suggest renaming the 2 folders in the Blynk library to be suggestive and directional. So instead of naming the first folder “libraries”, perhaps something like “extractContentsToArduinoLibraries”. My reasoning is because my first try at following your instructions, I moved the entire libraries folder to the Arduino/Libraries folder so then it was /Arduino/Libraries/libraries which of course gave me an error. At any rate, thanks for the tip.