BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

ESP 8266 12E device offline

Hello guys,
i have a NodeMcu ESP 8266 12E dev kit. I set up the Arduino Ide to use it with the esp.
I used the esp8266 standalone sample and put in my auth token, ssid and pass.
no errors with upload. on the blynk app i`ve choosen the right device and connection type wifi
but when i now start the projekt with the playbutton it always says device is offline.
in the homenetwork overview i can see that the esp is connected.
I dont know whats the problem here. i looked at many getting started guides but cant find anything im doing wrong.
what could i try next?
thanks

Hello
I’m new to these things, both in this space and in the world of things on the internet. I recently discovered the ESP8266 and have tried some experiences but I have not managed to get things working.
So I am now trying a project I found here (http://www.instructables.com/id/ESP8266-ESP-12Standalone-Blynk-101/?ALLSTEPS) with a NodeMCU module and I have the same Prioscape problem.
I saved the code with Arduino IDE with the data of my network and BLYNK and I can not go online.
What to do ?

Have you tried reading the debug info in the Serial monitor?

http://docs.blynk.cc/#blynk-firmware-debugging

also try one of the WORKING … off the shelf examples for your hardware… http://examples.blynk.cc/

1 Like

In de Serial Monitor nothing appears.

Then you obviously have not setup debugging correctly as it should be showing EVERY bit of info available.

What do you mean by that?
I copied the code to the IDE I entered the data from the network and Blynk and recorded. What should I do more?

Something has to be wrong. I just do not understand what.

Did you see the link I posted?

@toco the Instructable is dated June 2015, almost before Blynk existed.

Treat any Blynk sketch older than 1 month with caution as it is an ever changing environment.

Sorry but I’m really new to these things and I’m taking the first steps. I chose this project because it seemed simple to begin with. I also apologize for “my English” but I am writing for Google translator because I am Portuguese and I do not know how to write English. I read but I do not know how to write.
That said, yes I tried to follow debugging in the Monitor Series but in addition to “Œ BŒòonžlooœâä # p” c $ `r $ pònà" that appear after debugging, nothing else appears

This means you have teh wrong baud rate set. The serial monitor baud should match your sketch Serial.begin(9600) for example.

In Portugal we say “Who knows, Know.”
This is one of those simple things that upset a newbie.
Tina the speed at 115200 I changed to 9600 and now in the serial monitor repeats consecutively:

[1580316] Connecting to cloud.blynk.cc:8442
[1585317] Connecting to cloud.blynk.cc:8442
[1590318] Connecting to cloud.blynk.cc:8442
[1595319] Connecting to cloud.blynk.cc:8442
[1600320] Connecting to cloud.blynk.cc:8442
[1605321] Connecting to cloud.blynk.cc:8442
[1610322] Connecting to cloud.blynk.cc:8442
[1615323] Connecting to cloud.blynk.cc:8442
[1620324] Connecting to cloud.blynk.cc:8442

From what I understand, it can not connect to the server.
Did I start the project badly at Blynk AP?

cloud.blynk.cc died 12 months ago it should say cloud-blynk.com. Install latest libraries, latest app, latest sketch.

I will repeat:
“Who knows, Know”
I have a lot to learn …
And a lot of experience to win.
Now I begin to realize why all the codes I’ve tried so far do not work.
There is always a detail that we do not know.

Okay, I’ll see how I can update everything and then I’ll come back here.

Thank you very much

Also for you, Jamin

1 Like

Jamin, please tell me what the second link is for?

Its a new example explorer created by Blynk.

It will let you (almost) copy and paste a working example. Just update the Auth, Wifi name and password… and it should work if you follow the instructions at the top of the sketch.

Start with the PushData example as once you learn that, you can build almost anything from it.

So much to test …
But now I have to go to bed because it’s almost two in the morning and I have to go to work in a little while.
Thank you

1 Like

There you go @Jamin @Costas - you both should put that in your title :slight_smile:

Mine is going to say IDK :wink:

Here I am again.
I updated the libraries I reinstalled the APP but I did not change the sketch because I do not think I have to do it.
I am still disconnected although the behavior is different.
The same type of message appears in the serial monitor but slower:

[3746844] Connecting to blynk-cloud.com:8442
[3759990] Connecting to blynk-cloud.com:8442
[3773187] Connecting to blynk-cloud.com:8442
[3786421] Connecting to blynk-cloud.com:8442
[3799611] Connecting to blynk-cloud.com:8442
[3812762] Connecting to blynk-cloud.com:8442

In the APP Android I have a message with yellow letter that appears and disappears and says “Device has been disconnected”.
I think you’re connecting and disconnecting from the server.

Many things have changed since the cloud-blynk.cc days.
Some sketches from back then will not work.
I would obtain a new token, enter it in an up to date sketch, reflash and see if you get online.

There is a standalone sketch in the IDE and on GitHub. These are the official sketches and are permanently up to date. You should assume any other sketch you see will need revisions to keep up with the library changes.