Esp-07 add device problem

My ESP-07 module is unable to keep the device data and wifi credentials after reboot.
After uploading the program to the ESP-07 and adding device through the Blynk IoT android application, my program works well, but after disconnecting and reconnecting power to the module, the module led starts blinking rapidly which means it is waiting for device connection.
Also the device shows offline in the blynk dashboard.

The same sketch works fine with Blynk Legacy, I have been using it for many months, but now I want to migrate to Blynk 2.0 and this problem is occuring.

Please help, do ask for any more details I will provide it.

You are probably using the reset pin elsewhere in your code or that GPIO is pulled low.

Check your settings.h file. See which pin you have defined. And see if you have anything connected to that pin.

In general it should be in high state. When we push the button, we are pulling it low and executing the reset procedure.

Reset GPIO ——-> BUTTON ——-> GND.

Read this for more info…


Do you mean the flash pin which is GPIO0 ?
I am not using this pin anywhere in my code.
by default pin ch_pd is connected to vcc by a 10k resistor and gpio15 is connected to ground by a 10k resistor, and I have attached an led to gpio12, rest all gpio pins are unused.
When the device is first provisioned it is working successfully, as soon as the device is powered off and powered on again, it loses its provisioning.
I have even tried pulling gpio0 to vcc but no luck.

board type : esp8666(esp-07)
board type used in sketch : nodemcu/d1mini
board button pin : gpio0
board button active low : true

Sorry sir for posting this issue here since i don’t know where else to post it.
I am not asking for provisioning and re-provisioning procedures.

The device is being provisioned well the first time and working successfully, but as soon as I am powering off the device and powering back again, the provisioned details are cleared, I have not used gpio0 anywhere in my sketch, neither it is connected or being pulled low, alternatively I also tried to keep it high but still the device’s provisioning is cleared after restarting the device.

If the reset button / Reconfig button defined in the settings.h tab is pulled low. After the board boots it automatically resets the credentials and ask you to input the wifi creds.

Connect your board to your system open the serial’s monitor.

Configure your device like you normally do.

Now reset the board and see what the serial monitor has to offer.

Post the serial monitor output here with triple backtics (```)

When the board is first configured

[26607] Sending board info...
[28869] Applying configuration...
[28870] WiFi SSID: CPPLUS Pass: xxxx
[28870] Blynk cloud: nw_hw9wIqXFmJS2N_V11rpwDkuv_IhkE @
[28876] Switching to STA...
[29980] Connecting to WiFi: CPPLUS
[34305] Using Dynamic IP:
[49843] Current time: Sun Aug  7 09:32:56 2022
[49843] Connecting to
[51893] Ready (ping: 12ms).
[52116] Configuration stored to flash

after connecting rst to gnd

    ___  __          __
   / _ )/ /_ _____  / /__
  / _  / / // / _ \/  '_/
 /____/_/\_, /_//_/_/\_\
        /___/ v1.0.1 on ESP8266

[386] --------------------------
[389] Product:  CAR
[391] Firmware: 0.1.0 (build Aug  7 2022 12:58:05)
[395] Device:   ESP8266 @ 80MHz
[398] MAC:      C8:C9:A3:6F:E2:A7
[401] Flash:    1024K
[403] ESP core: 3.0.2
[405] ESP SDK:  2.2.2-dev(38a443e)
[408] Boot Ver: 31
[410] Boot Mode:1
[412] FW info:  468976/1626112, MD5:c209fa0a19a4f2c8bb74b16b658acbfa
[619] Free mem: 31048
[620] --------------------------

[1230] AP SSID: Blynk CAR-A7C0F
[1231] AP IP:
[1231] AP URL:  blynk.setup

Are you using EEPROM to store data in your project?

Please post your code. Or else it would be hard to troubleshoot.

this is the main file, rest all header files like edgent.h are unchanged


#define BLYNK_FIRMWARE_VERSION        "0.1.0"

#define BLYNK_PRINT Serial
//#define BLYNK_DEBUG

#define APP_DEBUG

// Uncomment your board, or configure a custom board in Settings.h
//#define USE_WEMOS_D1_MINI

#include "BlynkEdgent.h"

const int headlight_pin = 12;
bool headlight_val = 0;

  headlight_val = param.asInt();
  digitalWrite(headlight_pin, headlight_val);

void setup()


  pinMode(headlight_pin, OUTPUT);
  digitalWrite(headlight_pin, headlight_val);
  Blynk.virtualWrite(V0, headlight_val);

void loop() {;

arduino ide configurations that i am using

Why are you choosing NodeMCU as your board type?

Is your ESP-01 really one of the 4MB versions?

What exactly do you have connected to pins GPIO0 and GPIO2 ?


1 Like

thank you.
that did help, since previously i was using blynk legacy those settings were not causing any problem in that, but for the newer version of blynk and all those provisioning thing, the board type should be generic esp8266 with 1 mb flash.

1 Like