ESP-01, arduino MEGA2560, blynk... ESP is not responding

Hello, I have a problem with esp-01. I am trying to use it with arduino mega2560 & blynk. When I try to use blynk arduino mega example, I get error: “ESP is not responding”. I’ve been trying to fix this error for like 15 hours searching every forum, every tutorial i could find… I have even tried to use new jumpers between arduino, breadboard and esp8266. I tried switching every combination of TX=>RX RX=>TX OR TX=>TX TX=>RX and baud rates… still same error. Then I realized that almost all AT commands give me ERROR, so I flashed some newer version, but I am not able to flash using “flash_download_tool_3.9.2”. It just keeps syncing forever and it prints “…” in cmd. I’ve even tried “flash_download_tool_v3.8.5” but same error. I’ve noticed that I can flash the firmware only using “esp8266_flasher” (with RX=>RX and TX=>TX. When I do otherwise and try to upload a sketch from arduino, the whole ide just keeps loading after hitting upload button) which takes only one .bin file. I couldnt find latest version in one .bin file, so I have "AT version: SDK version:1.5.4(baaeaebb)
" at the moment. AT commands finally works, I can connect ESP to my wifi via AT commands, I can ping the ESP from my computer, but I still get that “ESP is not responding” error while trying blynk example. I tried to upload sketch with programming pin to GND or without, or with reset pin… nothing changes the “ESP is not responding” error. Right now I have set the baud rate to 9600 in both esp-01(AT command) and arduino. Does anyone have any idea to fix it? I think I am going insane…:exploding_head: Also sorry for my english. Some more info:

 SPI Mode       : DIO
 SPI Flash Size & Map: 8Mbit(512KB+512KB)
 Blynk version: 1.0.1

Post you sketch and wiring diagram please.

I’d start by reading this…

I don’t really understand the part where you said that you’ve flashed new AT firmware to your ESP-01 using the Arduino IDE. As far as I’m aware, that’s not possible.

I also don’t understand this part…

It sounds like you are trying to upload the sketch to the ESP-01, rather than the Mega.


1 Like

Thank you so much. I read your “Understanding hardware and software serial ports” post and noticed that you mentoined 18 and 19 pins there. I’ve been using pins 0,1 the whole time. I didn’t find it wrong because I used to flash firmware through these pins(esp8266_flasher) and also the esp-01 was blinking blue while uploading a sketch from arduino while using these pins. So changing the pins from 0,1 to 18,19 solved the problem, thanks.

1 Like

Good, glad to hear that it was worth taking the time to write that guide.