Error Connecting To Local Sever

I have my local server running I am trying to edit the raspberry client script to look for my local server can some one please help. I am learning as I go I am currently looking in /usr/lib/nde_modules/blynk-lib/bin/blynk-client.js

Should be something like this :

var blynk = new Blynk.Blynk(AUTH, options= {addr:""});

Ok so I need to replace
various blynk = new Blynk.Blynk (process.argv[2])…?
Is that correct.


1 Like

Thanks you thats what I thought you have been a great help!

var blynk = new Blynk.Blynk(AUTH, options= {addr:“”});
ReferenceError: AUTH is not defined
at Object. (/usr/lib/node_modules/blynk-library/bin/blynk-client.js:12:29)
at Module._compile (module.js:456:26)
at Object.Module._extensions…js (module.js:474:10)
at Module.load (module.js:356:32)
at Function.Module._load (module.js:312:12)
at Function.Module.runMain (module.js:497:10)
at startup (node.js:119:16)
at node.js:906:3

??? sorry to be a bother…do i need to set a variable for AUTH?
This is what I have.

In your case it should be process.argv[2]

1 Like

Thank You.

Ok Got the IP set now I need to change the port it is could you lead me in the right direction.

This is just a guess… heaven knows my RPi experience is shaky :wink: But perhaps use x.x.x.x:port ?

1 Like

var blynk = new Blynk.Blynk(process.argv[2], options= {addr:“”, port: xxxx});

working though SSL not authorized

I ment ...options = {addr:"}); But again, not sure if that will work in this context.

Gotcha may try it just so we know I am new to this so learning as I go.

it throws a syntax error

OK, try this
...options = {addr:"", pppp});