Email connection problem

Hi I have install Blynk local server using SensorsIOT stack in a docker container running on Ubuntu 20.04.2. I have accessed the admin page on port 9443. On that page I can enter an email address (Gmail) and my password. I have set up the Blynk app on my Android tablet. I have set up a user account and a project with a few controls.
However, when I try to send the authentication code via email I get an error ‘Unable to send email, please check network connection’. If I go back to the admin page I can get the authentication code from there. If I install that same code into the Node-RED write node I can receive data from the Blynk app on my tablet , so the system is working.
I looked for an answer on the the net and on this forum and a suggestion was to enable ‘less secure’ access on Gmail, I did this and still I cannot get the ‘Send email’ to work.
Do I need to set up a specific Gmail account just for Blynk?
I have tried this set up on two separate machines (Dell Wyse thin clients) and the email does not work on either although the email address is the same.
Can anyone help to solve this issue please.

This information needs to go in the file, and if you edit this file via the admin page the settings aren’t saved, so you have to edit the file directly. This can be a little tricky when using Docker, which is one of the reasons why I don’t use it anymore.

No, but your Gmail account need to be set to “allow less secured applications”, so some people prefer to have a separate Gmail account.

Have you read and followed the instructions here:

Not connected to this issue, but if you’re a Node-Red user then I’d suggest that you run MQTT code on your devices, and use Node-Red as the single bridge between Blynk and your network.


Hi Peter,
Thanks for the prompt response. I did try using the ‘less secure’ setting as I mentioned in my post, no joy there. I had also tried editing the mail. properties file on the admin page but despite getting the ‘saved successfully’ message when I checked back the settings had reverted to the default settings.
I’ll work through that page as you suggested again, I have looked at it previously. If I get no joy I could try installing Blynk server without Docker.
I do use MQTT and I am using node-RED as a single bridge as you suggest. I read your posts regarding your Blynk / node-RED adventures yesterday, very good too!
Apart from this email issue everything is working well so if I have to give up on it , I will as I can get the authentication codes from the admin page anyway.

I solved my issue with regard to my email connection so I’ll post what I found in case others have the same problem. Specifically I am running Blynk local sever under the SensorsIOT stack system which is Docker based, furthermore I am running it on Ubuntu 20.04.2. I must say the Sensors IOT stack system works flawlessly provided one carefully reads all the comprehensive documentation. The email credentials are set up in the config file which is easily found using WinSCP to access the remote Linux device.
The problem I encountered was due to the Chrome browser. For some reason, in the security settings, I had my email set up to use a code sent to my moby to validate the email access. When I removed that option and went for password authentication I got an error, ‘Invalid password’ once I reset my password and updated the Blynk server config file I could send my Blynk project authentications without issue.
I would highly recommend the SensorsIOT method of installing Blynk local server as it is easy to install, keep up to date and change the configuration files without needing to mess with Docker.
Chrome is OK but has a few ‘Gotchas’ for the unwary.