BLYNK
BLYNK.IO       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Edgent_esp8266 on wemos d1 mini need HELP

hello, i tried to upload a basic pushbutton code using blynk 2.0 to my wemos d1 mini, but this error message appears:

C:\Users\JAPITAN\Documents\Arduino\libraries\blynk-library-master\src/BlynkSimpleEsp8266_SSL.h:91:53: error: ‘class axTLS::WiFiClientSecure’ has no member named ‘getLastSSLError’
int err = this->client->getLastSSLError();
^
exit status 1
‘class axTLS::WiFiClientSecure’ has no member named ‘setTrustAnchors’

any help is much appreciated guys, thanks in advance

1 Like

Are you using the Edgent ESP8266 example?
If so, what board-type did you un-comment in the #defines at the beginning of the sketch?

If not, then please post your sketch (correctly formatted with triple backticks of course).

Pete.

Yes I used that example, and I uncommented the wemos d1 mini

let me post the code as well, i had just adapted this code from this video for esp8266, since i really had no idea what to do with the new blynk app:

#define BLYNK_TEMPLATE_ID           "TMPL******"  //template id intentionally censored
#define BLYNK_DEVICE_NAME           "Device"  //device name too

#define BLYNK_FIRMWARE_VERSION        "0.1.0"

#define BLYNK_PRINT Serial
//#define BLYNK_DEBUG

#define APP_DEBUG

// Uncomment your board, or configure a custom board in Settings.h
//#define USE_SPARKFUN_BLYNK_BOARD
//#define USE_NODE_MCU_BOARD
//#define USE_WITTY_CLOUD_BOARD
#define USE_WEMOS_D1_MINI

#include "BlynkEdgent.h"

BLYNK_WRITE(V0)
{
  int pinValue = param.asInt();
  digitalWrite(2, pinValue);
}

void setup()
{
  pinMode(2, OUTPUT);
  Serial.begin(115200);
  delay(100);

  BlynkEdgent.begin();
}

void loop() {
  BlynkEdgent.run();
}

@Jotaro please edit your post, using the pencil icon at the bottom, and add triple backticks at the beginning and end of your code so that it displays correctly.
Triple backticks look like this:
```

Pete.

Edited now

Could it be that I need to update my esp8266 boards?

1 Like

I don’t understand the question.

Pete.

I mean maybe the cause of that error message when I upload that code is that I need to update my esp8266 boards package to the latest version… idk really, maybe I could try to check tomorrow morning if that package is already at the latest version

You mean the ESP8266 core?
I don’t think that’s the cause of the issue, but keeping your ESP core up to date is a good idea.

My guess is that you don’t have the latest version of the Blynk library installed correctly.

Pete.

I’ll try to reinstall the blynk library as well, the one i have was from github that I’ve downloaded today

issue solved! i just had to update the esp8266 arduino core from 2.4.2 to 2.7… 2.7 coz when i update the esp8266 board core to the latest version (3.0.1), the original code in my wemos that is intended for an RC car wont work, so i had to upgrade to the slightly older than 3.0.1, which is 2.7… it seems that it has something to do with the SSL protocols in the older version, being incompatible with that of the blynk library… thanks guys

2 Likes

thank you! :heart_eyes:

you need to update esp8266 boards ver 3.0.2