Hi there,

Was looking into other similar topics an the Docs but couldn’t find the answer for the issue I’m experiencing.

RPi 3 B

Initially use “home” network and not a bother, got the device connected and small NodeJs code up and working.

Using my “work” network and I’m getting the error below

OnOff mode
Connecting to: 8441
SSL authorization...
Redirecting to : 80
Disconnect blynk
Connecting to: 80
SSL authorization...
      throw err;

Error: Uncaught, unspecified "error" event. (ECONNRESET)
    at Blynk.emit (events.js:163:17)
    at Blynk.error (/home/pi/.nvm/versions/node/v6.10.3/lib/node_modules/blynk-library/blynk.js:604:8)
    at .<anonymous> (/home/pi/.nvm/versions/node/v6.10.3/lib/node_modules/blynk-library/blynk.js:567:48)
    at emitOne (events.js:96:13)
    at emit (events.js:188:7)
    at TLSSocket.<anonymous> (/home/pi/.nvm/versions/node/v6.10.3/lib/node_modules/blynk-library/blynk-node.js:223:16)
    at emitOne (events.js:96:13)
    at TLSSocket.emit (events.js:188:7)
    at emitErrorNT (net.js:1277:8)
    at _combinedTickCallback (internal/process/next_tick.js:80:11)

I’m using blynk-client to test communication and I’m getting the error above.

Any help is very much appreciated.

*** UPDATE****

Was able to make it work by using TCP connection via a simple node app adding the code below

var blynk = new Blynk.Blynk(AUTH, options = {
  connector : new Blynk.TcpClient()

It leads me to believe some issues using SSL connection

Through the CLI calling blynk-client I’m still not able to do it.

See here…

Hey @Gunner

How can it be achieved as it seems to default to 8441?

And again, on my “home” network I didn’t experience any issue whatsoever.

Thanks in advance.

Perhaps? update all Library, server and App versions to latest.