[DUPLICATE] Blynk Ethernet Shield 2 not working? (W5500)

Hi guys!

I’m new to the whole blynk and arduino scene and trying to get my head around it all.
Bought a ethernet shield for my Arduino Uno Rev 3 and have been trying to get the dam thing to connect to the internet. Tried using the default “auth” and even the static IP from the example sketch. But every time I try and start it, the serial monitor says:

[0] Blynk v0.3.1
[0] Using static IP
[1300] My IP:
[5001] Connecting to cloud.blynk.cc:8442

The funny thing is I actually have set my IP to something completely different???

Anyway, in advance here is the code I have used in my sketch:


  • Blynk is a platform with iOS and Android apps to control

  • Arduino, Raspberry Pi and the likes over the Internet.

  • You can easily build graphic interfaces for all your

  • projects by simply dragging and dropping widgets.

  • Blynk library is licensed under MIT license

  • This example code is in public domain.

  • This example shows how to configure static IP with Ethernet.
  • Be sure to check ordinary Ethernet example first!!!


```#include <SPI.h>
```#include <Ethernet.h>
```#include <BlynkSimpleEthernet.h>

// You should get Auth Token in the Blynk App.
// Go to the Project Settings (nut icon).
char auth[] = "Auth code goes here obviously";

// Mac address should be different for each device in your LAN
byte arduino_mac[] = { 0x90, 0xA2, 0xDA, 0x10, 0x13, 0x83 };
IPAddress arduino_ip ( 192,168,0,135);
IPAddress dns_ip     (  8,   8,   8,   8);
IPAddress gateway_ip ( 192,   168,   0,   1);
IPAddress subnet_mask(255, 255, 255,   0);

void setup()
  Blynk.begin(auth, "cloud.blynk.cc", 8442, arduino_ip, dns_ip, gateway_ip, subnet_mask, arduino_mac);
  // Or like this:
  //Blynk.begin(auth, "cloud.blynk.cc", 8442, arduino_ip, dns_ip, gateway_ip, subnet_mask, arduino_mac);

void loop()

Can anyone be my saviour? 

Thanks a million,

Have you tried connecting via DHCP? Your setup looks correct. Sometimes it helps to reset your router/modem.

Hi Lichtsignaal!
yes yes i tried all that still nothing, I ust don’t understand why it’s pretty much not accepting the IP I’m giving it?

Have you tried simple sketch without any connection settings? What shield do you use?

Hi Dmitriy, I have the Arduino ethernet shield 2. I have tried using the simple sketch with no connection settings and it just says “getting IP”, so don’t know if that helps ?

Thanks, Paul.

W5500 is not supported yet. @vshymanskyy

Hi Dmitriy, do you know when it becomes supported? cheers paul.

I tagged @vshymanskyy so he could provide us with estimates.

Hi Dmitriy, been a while still no estimates? is it possible for you to give me a rundown on how long until compatibility? thanks paul.

I think there is some progress over here: [SOLVED] Arduino ethernet shield 2 (W5500)

1 Like

Yeap, look like it should work with minimum modifications (but we still don’t have this shield) see above link.

Just submitted an example for Arduino Ethernet Shield 2 (W5500): https://github.com/blynkkk/blynk-library/blob/master/examples/BoardsAndShields/Arduino_Ethernet2/Arduino_Ethernet2.ino
You will have to use latest Blynk from master branch.

Please check it and tell if it works (I don’t have this hardware to test).
Thank you!

Hi vhymanskyy,
I have a quick question for you, where can i find Ethernet2.h? I have updated Arduino IDE to 1.6.7 and still can not get it to find that library! sorry new to the world of Arduino, help will be much appreciated.

Thanks Paul.

@paul_williamss, mre details here [SOLVED] Arduino ethernet shield 2 (W5500)
please also continue discussion there, to keep this in one place.