"Download CSV file" in History Graph

Hi, running a local server here, just updated to 0.23.1

I’m trying to make “Download CSV file” work.
I saw the thread about the IP address issue, applied the fix suggested and I can confirm that it works (got correct IP in the link).

However, after selecting the link, I get a “Failure: 404 not found” message.
The linked address looks like this:

Yesterday, before server upgrade, it worked, and I was able to download the file. In that case the downloaded file was named 1-0_v4-2017-02-05.csv.gz, so, it looks like the current file path may be missing a piece?. Not sure what’s changed since yesterday. I even rolled back to previous server version, with same result.

(Please note that 8090 port is not a typo, I had to configure another port because 8080 was already used by another device…)

Any hint?

Thanks for report. I’ll check.

I wasn’t able to reproduce. What OS are you on? How do you generate the link to files?

I’m running the server on a Raspberry Pi 3, which has the osmc variant of Debian. To be more specific:

osmc@osmc:~$ cat /etc/os-release
PRETTY_NAME=“Open Source Media Center”
VERSION=“November 2016”


To get the link, I simply drag the graph to the left, this exposes the “Download CSV File” button, I click on it and after a few seconds I get the email which contains the link. The link text is the Blynk project name and variable. By clicking on the link I get the 404 message.

Please note

in the previous email I see that the line with the linked address was someway scrambled by my usage of brackets and underscores, which confused the html text editor. Sorry I didn’t notice it before.
The linked address looks like this:
http://[my IP]:8090/[my login]_2_v2.csv.gz

Does this works for you - http://docs.blynkapi.apiary.io/#reference/0/pin-history-data/get-all-history-data-for-specific-pin?

Thanks, I tried, the http address suggested by the docs, after pressing return, turns into the following address

http://[my IP]:8090/[my login]_1_v2.csv.gz

Same result (404 error).
I suspect something “nasty” happened at server version change on my machine (depending on active projects?).

I’m considering re-building the project from scratch on the app (new token) and see if the issue is still present.
Does it make sense? Better suggestions?

Do you see some errors in blynk.log? If not please try to enable “debug” in server.properties and check logs again. YOu can also try latest server I just release 0.23.2.

Dmitriy, the log investigation didn’t show any error, however, after server upgrade, the link on the email began to work!
The linked address is exactly the same as before, but this time by clicking the link, I get the file.
The same emails that yesterday got 404 err, now, clicked again, they get the file.

Thanks again, it seems that the problem is fixed! :relaxed:

Hm. Interesting. Goog to know and thanks for reporting back!