Don't just label pins as busy

Instead of labelling pins as “Busy” when they are in use, perhaps you could show in the GUI the name of the widget currently assigned to a pin? This would make implementing complex projects easier. Even better would be to find some way of naming the pins (perhaps via an autogenerated constants.h that could be generated in the app and pulled down into the arduino code at compiled time?).

1 Like

Great ideas, we will consider fhem. Thanks for sharing. :+1:

Naming the pins sounds complicated, and there are no tools for that. Maybe in case of serious integration with Arduino Create it will be possible, but now it’s sci-fi :slight_smile:

If you have ideas on how it can be done - please share.

I write my pins in a spreadsheet… Otherwise it gets #u#g#u#l#y#

Oh no :scream: It should not be this way.
Do others have the same issue?

How about:

#define ONSWITCH V1
#define VOLUME V2

The challenge is sending the data from the app to the arduino ide - maybe it’s something you could serve up from the cloud?

I’ve done that as well. I like that I can use to get everything, but it would be more helpful if I learned PHP or something so I could intelligently parse and display that information sorted by vPin, Label, etc.

  1. It complicates everything. Instead of tracking a fixed stuff, which is pin #, you are suggesting a dynamic process, which may lead to numerous user errors. And while it sounds simple to use names, it creates tons of complexity in terms of UX by connecting the dots between app and code. It’s much easier to add a comment for yourself in the sketch.
  2. Arduino IDE is not connected to any cloud… yet. Arduino Create might make it possible. But such integrations involve significant development effort and requires deep partnership relationship. It sounds easy, but it’s not :slight_smile:

We will think on how this process can be improved, but Virtual Pins are here to stay, until a better concept will be ideated jointly by you and us.

So labelling pins in the app with the widget is not complicated - you can definitely do that.

I still think naming the pins in the code is nice-to-have. This could be an optional feature (energy consuming even?) for more experienced users. I admit the compile-time dependency isn’t especially clean - but I’d argue the dependency is there anyway, at least with vitrual pins. Users have to take care not to get there Vn pins confused already. It’s not obvious to me that naming them makes this any more confusing - it my well be easier to manage.