Difficulty moving widgets between tabs on the android app

I am having difficulty moving widgets between the tabs. Worked fine in Blynk 1.0. Is there a knack to it? It’s a bit hit and miss. Mostly miss - almost impossible.


What did you mean difficulty? You need to hold and drag the widget to the tab name.



Thanks for replying.

Yes I understand how it should be done. I’ve been doing it for several years on V1.0. So it was a surprise.

I just can’t seem to place it on the tab name so that the tab will open and allow me to place the widget on the tab page. It sometimes randomly opens another tab.

What does seem to work for me is moving a widget to the last tab. So that, in a round about way, solved my problem. I just move the tab to to end, did my moving and then moved the tab back to the correct sequential position.

Can I suggest you test it with a few more than 3 tabs and make the tab names longer so the tabs have to scroll horizontally?

If you can do it OK then fine. Your fingers have more magic than mine do :). I have my workaround now. And I don’t do it often - just at the moment finishing off my conversion from V1 to V2.

I just thought I would mention it incase it is a common UI problem.


1 Like

Sharing information about whether you are using iOS or Android, and which version of the app you are using might be helpful.


@koaiwi i confirm the problem. I also had the same difficulty. I tried moving the widget towards the end at first, as you discribed and it seemed to work somehow.
Maybe , maybe , the problem starts when after you create the tabs , you rearrange their order. Maybe the tab bar, does not update their new position only when it comes to moving widgets from a tab to another, and not when you activate each tab.
A lot of maybes because i am not sure for the second sentence. Just a wild guess.

Not difficulty with long tabs name. You can scroll tabs in dev mode and move widget to any tab


@Liq @koaiwi please provide you dashboard screenshots with tabs.

And what phone model and OS?

Hi Pete. Android app. v1.7.4(105) 12.12.2202.

Huawei P9. Android.

4 tabs. UFH, Hot Water, Fan @ Towel Rail, Status.

Hi. Were you able to replicate the issue. I have the same problem on my android levano tablet as well.


We checked everything works correctly. What version of the app are you using?

As per above along with my screen shots.

My gut feel is there must be a very obscure issue. There are at least 2 of us with the same observation and both my devices have the same quirk with this template.

Would having my email and server details help? I have created a copy of the offending template if you wanted to have a play to try and replicate my observations.

  1. Another user described the problem that the widget cannot be moved to the right place after copying

We checked. It works. After copying to another tab, you can immediately move it to the right place

About your tabs

4 tabs. UFH, Hot Water, Fan @ Towel Rail, Status.

We tested with such tab names, everything works correctly. Including on phones with a small screen.

So it’s something more obscure then.

Let me know if you are happy with your observations and do not consider it an issue or you would like to investigate further. I could help.

Ideally you would want to run my full template on your device with your finger doing the work.

We are having trouble reproducing this issue: we tried several very different smartphones and had not reproduced it on either of them. May we ask for a screen capture of the issue from your device?

Looks like we fixed the issue and it the fix will be available with some other minor changes/fixes in 1.7.5 at the next week beginning.

1 Like

Pleased that it’s fixed and my example helped zero in on it. Good that it wasn’t my fat finger that caused the issue. Some bugs are just plain obscure.