BLYNK
BLYNK.IO       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

"Device offline" message shown in latest Blynk 2.0 app

Hi. I am trying to turn ON and OFF an LED using the Blynk app. I had created a template and virtual pins using blynk.cloud webpage. However whenever I try to find my ESP 8266 in the Blynk app, a message is shown “Device offline”. Below is my coding. Hope someone could kindly assist me with this issue. Thanks in advance.

Code:

# define BLYNK_TEMPLATE_ID = " "
# define BLYNK_DEVICE_NAME = " "
# define BLYNK_AUTH_TOKEN = " "
# include <BlynkSimpleEsp8266.h>

char ssid[] = "";
char pass[] = "";

BLYNK_WRITE (V0)
{
int pinValue = param.asInt ();
digitalWrite (15,pinValue);

}

void setup()
{
pinMode (15,OUTPUT);
Serial.begin (9600);
delay (100);


}

void loop()
{

Blynk.run();

}

Hey there.
Edit your post and add triple backticks at the beginning and the end of your sketch please, triple backticks look like this ```.

hi, ok

Make sure to fill the template ID and device name and auth token and delete the delay from the setup

Yes, i did. I just removed it in this post

Now go to the app, add a widget and assign it to the datastream

yes i did

after that I tried to ‘add device’. still my device is not found

Just make sure the template ID and auth token are correct.

they are correct because I directly copied it from the blynk.cloud webpage under Device info

void setup()
{
  // Debug console
  Serial.begin(115200);

  Blynk.begin(auth, ssid, pass);
  // You can also specify server:
  //Blynk.begin(auth, ssid, pass, "blynk.cloud", 80);
  //Blynk.begin(auth, ssid, pass, IPAddress(192,168,1,100), 8080);

  pinMode (15,OUTPUT);
}

tried it. still it shows device offline

Are you using nodemcu ?

yes NodeMCU v3

Try a different pin please

ok, but is device connection related to pin connection?

It’s just a test

What does your serial monitor show when you boot-up your NodeMCU?

Pete.

1 Like

thank you everyone. The issue has been solved. The issue was with the UART cable that I used to connect from my PC to the NodeMCU. I have changed it, now it works fine…