BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Device lost in application

#1

Hello,

I have a problem with device lost in application. I have two devices ESP8266 connected to blynk cloud and starting from Sunday evening i face this problem. The devices themselves continue their work properly, but they are offline in the application. Only device restart helps. On Sunday evening I need to restart my devices each 10 minutes, because of connection lost in app, Then everything worked properly till the Monday evening. The same stuff for Monday evening - several restarts each 10-30 minutes. The last restart was made this morning (7 am CET). And now one of the devices is online, but the second one is offline. And more thing, the both devices were online in the morning, but the app shows, that the second device is offline since 10:48 PM Feb 26, 2018, which is definitely not true.
The app version is 2.18.2. Server - blynk-cloud

0 Likes

#2


As can be seen on screenshots, the data in the superchart is still visible for the last hour, the offline time is set to 10:48 PM yesterday.

0 Likes

#3

Are you using a DHT11 or 22 sensor by any chance?

As you’ve not posted your code, it’s difficult to tell if this is down to poor coding, but there seem to be similarities with this thread:

Pete.

0 Likes

#4

Please tell me your login email. Is your device “oflline” in app right now? How do you know that device works? By history graph?

0 Likes

#5

My email is xx. I I know, that it works, because I’ve tested it this morning before restart. And, actually, that is not the first time the issue occurred, so I know for sure, that it works. I use DHT22, but I don’t think it’s related somehow. I tried using the plain Blynk example and had the same issue. I have this problem since 2.18.0 version of app. Then it was fixed (I believe) in 2.18.1. But starting from 2.18.2 the issue came back.

0 Likes

#6

@shur1k have you modified devices somehow recently? I mean - did you edit device settings, maybe name or board type?

0 Likes

#7

One of them was just updated with new firmware without settings change. The second one, I don’t remember for sure, but it may be, that the board type was changed from ESP8266 Generic to NodeMCU.

0 Likes

#8

I looked into your data and see that last time second hardware was actually connected is 5:56 today in the morning.
Is that correct?

However, disconnection time is wrong, that is true. This is actually a blynk bug.

0 Likes

#9

If we are talking about UTC, then yes, looks like correct. approximately 06:00 UTC.

0 Likes

#10

Yes. UTC. So for wrong disconnection time I created a ticket. However, regarding status - seems like hardware just didn’t connect.

0 Likes

#11

But, the HW is alive and works as expected, just don’t see it in the app. What maybe wrong there? Should it reconnect automatically, if the the signal was lost (WiFi reconnect or something like that)? Or does it require some additional code in the device to check the connection and reconnect in case of problems?

0 Likes

#12

@shur1k how do you know the HW was working fine throughtout the period?

ESP8266 may or may not reboot on error, it depends how you flashed it and what the error is.

0 Likes

#13

My device has also hw buttons and relays attached to it. And everything remains in the working state when the device disappears from the app.
P.S. I don;t use a watch dog timer.
I also tried to power my device from the PC with the serial port active. And there were no messages to serial port when the device disconnected.

0 Likes

#14

You do, all ESP’s use a WDT.

What does tried mean, you hooked it up before or after the disconnection?

0 Likes

#15

Maybe I use it, thanks!
It means, that the device was initially powered from PC and connected to serial. And I saw the messages of connecting to WiFi and blynk cloud on a start. And after some time the device disappeared in app, but there were no messages in the serial port monitor.

0 Likes

#16

You should send periodic updates to Serial Monitor to be sure if your hardware is running or not. Say at 30s or 60s intervals during code debugging stage.

0 Likes

#17

But still, it doesn’t explain why the device disconnects from the server in silent mode.

0 Likes

#18

If you’re using the Arduino IDE serial monitor it can often become unresponsive in my experience. When it does this is will stop displaying the serial output and you need to close and re-open the serial monitor for it to start working again.

Pete.

2 Likes

#19

What is your understanding of silent mode?

Without Serial Monitor data it’s very difficult to resolve your issue.

0 Likes

#20

My understanding of silent mode is, actually, the serial data absence.

0 Likes