Data send problem - data not registering in datastream

ESP8266 wifi
Android smartphone OS version 12
Blynk server

I have an ESP8266 sending temperature data to several graphs. Some of them stopped receiving data. The code has not changes. Specifically, virtual variable V19 all of a sudden stopped receiving data.
Everything in the code looks fine.
I tried erasing all data but this did not help.

here is what sennds the data (I have been using thois code for over a year and it always worked):
Blynk.virtualWrite(V19, sum2 / meas_count); // V19 - outside trend

Could there be a problem with the server’s data stream?

I also had a problem with V32 and V33 they stopped receiving.
I deleted V32 and V33 and created V34 and V35 to replace them. These update at midnight so I will have to see if they work.

Is there any way I can check the datastreams? Could they be broken? My V17 and V18 are the same and they are working fine.

@mike1950 I’d suggest you edit your post and provide some useful information about whatever issue it is that you are experiencing.


I updated the post. Please recheck.

Do you have “Enable history data” enabled for your datastreams?

Have you tried adding Labeled Value datastreams attached to the same widgets to see the values in a different format?

Do you have any data invalidation rules set up in your datastreams?


I will check these. The history switch might have been off.
I made all the settings equal and now it is working.

How does the “Data Aggredation” and “Aggredation function” affect the downloaded data ?

Is there a way of clearing a single datastream? I did not see a way of selecting individual streams.

Thanks for the help.

When you aren’t using Raw Data, the values in the database are aggregated in the way you choose.
If you choose Average then the reported value will be the average of the values received/stored for that time period.
If you choose Min, Max, Sum or Count then the value returned will be the minimum value, maximum value, sum of all values or count of data entries for that period.
Much like the way that you select a column of values in Excel and the bottom ribbon bar shows the same info…


I’m not sure.