BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Connecting to blynk-cloud.com:80 without success

Dear Blynkists,

I tried to use Blynk on my Wemos D1 Mini Pro.
Just opened the example ESP8266_Standalone, didn’t change the code, just wrote my auth, ssid and pass like written in several tutorials.
Everything connects fine to WIFI. See below. But no connection to Blynk-Cloud… :frowning:

What is my fault?

Connected to WiFi
IP: 169.254.97.84
 
    ___  __          __
   / _ )/ /_ _____  / /__
  / _  / / // / _ \/  '_/
 /____/_/\_, /_//_/_/\_\
        /___/ v0.6.0 on ESP8266

Connecting to blynk-cloud.com:80
Connecting to blynk-cloud.com:80
Every second another try... and so on...

Any help appreciated!
I just read several topics here in Blynk-Community… tried several things (Ports, Server etc.) but nothing helped…

Thank you very much!!!

Your D1 Mini isn’t getting a proper IP address from your router. Maybe your router only accepts MAC addressed in its whitelist, or maybe you’ve run-out of addresses in the DHCP pool?
Or, maybe just rebooting the router will solve the problem.

Pete.

Thank you PeteKnight…

Neither nor, unfortunately.

Just 7 devices connected to my WIFI and no MAC-Filter on…

But still the same problem.
No Firewalls…

BTW
PING blynk-cloud.com in Terminal Console is working…
Is getting address 139.59.206.133

Any suggestions

What IP Address range is the rest of your network using?

Did you reboot your router?

Pete.

IP Address range is 2-253. Every other devices can connect without problems, even guest-ones…
There is no option in the code to define the local-network-ip-address. At SSID I’m writing the real name of the network, am I right?!?

#define BLYNK_PRINT Serial


#include <ESP8266WiFi.h>
#include <BlynkSimpleEsp8266.h>

// You should get Auth Token in the Blynk App.
// Go to the Project Settings (nut icon).
char auth[] = "***";

// Your WiFi credentials.
// Set password to "" for open networks.
char ssid[] = "Vodafone-90EB"; //real name of my network
char pass[] = "***";

void setup()
{
  // Debug console
  Serial.begin(115200);

  Blynk.begin(auth, ssid, pass);
 }

void loop()
{
  Blynk.run();
}

I was expecting your response to be “my IP address range is 192.168.1.xxx to xxx” or something similar.

It’s the first bit (the subnet) that I wanted to know.

Pete.

Yeah of course it is 192.168.0.2-192.168.0.253, sorry :slight_smile:
Router has 192.168.0.1

Okay, in that case your NodeMCU should end-up with an IP address in the 192.168.0.xxx range, not the 169.254.97.84 that you currently have.

Is it possible that you have another device on your network that is acting as a repeater or hotspot - a phone or a Wi-Fi repeater for example ?

Pete.

I just tried another Router.

load 0x4010f000, len 1384, room 16 
Connecting to *Network*
Connected to WiFi
IP: 192.168.1.183

   ___  __          __
  / _ )/ /_ _____  / /__
 / _  / / // / _ \/  '_/
/____/_/\_, /_//_/_/\_\
       /___/ v0.6.0 on ESP8266

Connecting to blynk-cloud.com:80
Connecting to blynk-cloud.com:80
Connecting to blynk-cloud.com:80
Connecting to blynk-cloud.com:80
Connecting to blynk-cloud.com:80
Connecting to blynk-cloud.com:80
and so on...

Same situation…
No connection to blynk-cloud.com
:frowning:

Ping to blynk-cloud.com is still working

PING blynk-cloud.com (139.59.206.133): 56 data bytes
64 bytes from 139.59.206.133: icmp_seq=0 ttl=50 time=34.177 ms
64 bytes from 139.59.206.133: icmp_seq=1 ttl=50 time=23.279 ms
64 bytes from 139.59.206.133: icmp_seq=2 ttl=50 time=30.655 ms
64 bytes from 139.59.206.133: icmp_seq=3 ttl=50 time=28.589 ms
64 bytes from 139.59.206.133: icmp_seq=4 ttl=50 time=33.088 ms

Well, you’ve made some progress. At least your device now has a proper IP address.
Try changing the port to 8080 like this:

  Blynk.begin(auth, ssid, pass, "blynk-cloud.com", 8080);

and/or specifying the actual IP address of your local Blynk cloud server like this:

  Blynk.begin(auth, ssid, pass, "139.59.206.133", 8080);

Also, you are using version v0.6.0 of the Blynk library and the latest version is 0.6.1 so it might be worth updating it.
What version of the ESP core are you using? (Tools, Board, Boards Manager and scroll down to ESP by ESP community - the latest version is 2.6.3).

If none of this works then try turning on debugging:

Pete.

Thank you PeteKnight,

Why I’m using these old versions? Because OSX is not supporting Python3.
I tried to re-compile the Wemos with Windows… Everything works fine.
So I have to figure out, how to get Python3 on my Mac…

/Library/Arduino15/packages/esp8266/tools/python3/3.7.2-post1/python3: no such file or directory

So you can now connect to the Blynk server with your D1 Mini Pro?
Should I mark this topic as “Solved”

Pete.

Yes. Beside the problem with Python3 on my 2018 Macbook Pro.
After manually installing Python3 now everything works fine…