"Connecting to blynk-cloud.com:80" No Longer Connecting on Blynk 1.0

Before creating the topic
(This bit for @PeteKnight :wink:

  1. Search forum for similar topics - :white_check_mark:
  2. Check http://docs.blynk.cc and http://help.blynk.cc/ :white_check_mark:
  3. Add details :
    • Hardware model + communication type. :white_check_mark:WEMOS D1R2
    • Smartphone OS :white_check_mark:iOS 14.6
    • Blynk server or local server - :white_check_mark: Blynk Server (Connecting to blynk-cloud.com:80
    • Blynk Library version - :white_check_mark:1.0.0 (I have also tried 0.6.1)
    • Add your sketch code. :point_up:Code should be formatted as example below.
#define BLYNK_PRINT Serial
#include <ESP8266WiFi.h>
#include <BlynkSimpleEsp8266.h>

char auth[] = "myAuth";
char ssid[] = "mySSID";
char pass[] = "myPWD";

void setup()

  Blynk.begin(auth, ssid, pass);
  // You can also specify server:
  //Blynk.begin(auth, ssid, pass, "blynk-cloud.com", 80);
  //Blynk.begin(auth, ssid, pass, IPAddress(45,55,96,146), 8080);

void loop()


I have been using Blynk for about 3 years now, I have about 15 continuously connected devices, mostly Wemos ESP8266, around my home which were all developed using Blynk 1.0 in Arduino IDE. Today I wanted to make a quick change to one of them, but when I compiled the sketch and tested the Serial Monitor (SM) output stuck at Connecting to blynk-cloud.com:80

Wifi connected no problem, every time and returned a valid IP.

For all my sketches I have always used this basic Blynk connection method - Blynk.begin(auth, ssid, pass); it has always worked in the past.

However, today . . . none of my sketches would connect after being freshly compiled - however all my existing devices remain connected (and can reconnect after a reset) with no problem.

Reverting to basics, I experimented with the Blynk_Blink sketch (above) and found that:

Blynk.begin(auth, ssid, pass); does not connect . . . but
Blynk.begin(auth, ssid, pass, IPAddress(45,55,96,146), 8080); does connect everytime . . (I pinged blynk-cloud.com to get my regional IP address)

Two main questions:

  1. What has changed to stop Blynk.begin(auth, ssid, pass); from connecting, and

  2. Why do all my existing devices continue to connect?


PS. I have done some experimenting with Blynk 2.0 . . . I’m still not convinced it’s the way forward for me, but probably will port some of the devices I use every day . . . So please no comments about “just upgrade already”; or “Blynk 2.0 is better” etc . . . I just want to try to understand why something has has work consistently for many years suddenly stopped working.

Hi Bill, what happens of you try IPAddress(45,55,96,146), 80) ?

It could simply be something that your ISP is doing, either with DNS or blocking port 80.


HI Pete,

Port 80 with the IP address works fine (Blynk.begin(auth, ssid, pass, IPAddress(45,55,96,146), 80);)

⸮HA⸮G⸮lMH⸮⸮CI⸮⸮⸮⸮`⸮I⸮[69] Connecting to GoTigersEXT2
[6298] Connected to WiFi
[6298] IP:
    ___  __          __
   / _ )/ /_ _____  / /__
  / _  / / // / _ \/  '_/
 /____/_/\_, /_//_/_/\_\
        /___/ v1.0.0 on ESP8266

[6375] Connecting to
[6944] Ready (ping: 285ms).

Also existing sketches can reconnect no problem . . .?


What version of the ESP8266 core are you using to re-compile your sketches?

If it’s recently been updated then what happens if you downgrade it to an earlier version?


Hi Pete,

I did try that - 3.0.1 now, but downgraded to 1.7.4 which is pretty stable . . .

Solved now though . . . I notices that one of my sensors kept disconnecting/reconnecting every 30 seconds or so . . . but other sensors were fine . . .

I have my primary modem plus two WiFi extenders . . . some EXT2 devices (but not all) were dropping WiFi ten reconnecting (WiFi Manager in the sketches) . . . of course this is the WiFi segment I was attempting to connect to . . .

I rebooted the extender, and Blynk.begin(auth, ssid, pass); immediately connected . . .

So the mysteries of home wifi extenders continue . . .

All good now,

Hello. No changes on the cloud for the last few months. I think it has something to do with the firmware part.

Hi @Dmitriy , yes thnx. It turned out to be one of my WiFi extenders . . . a reboot fixed it. But very strange, it only impacted the newly compiled sketch, and two old sketches . . . the other attached devices had no issues . . . fixed now.