BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Connecting to blynk-cloud.com:80 error wont work on home router but works on mobile hotspot

hey i am having a problem while connecting to the blynk cloud.
error code :
[236020] Connecting to blynk-cloud.com:80
[239028] Login timeout
[241028] Connecting to blynk-cloud.com:80

i am using a nodemcu board with an android device

while i try to connect it to a mobile hotspot it work perfectly fine

arduino code:


/*************************************************************
  Download latest Blynk library here:
    https://github.com/blynkkk/blynk-library/releases/latest

  Blynk is a platform with iOS and Android apps to control
  Arduino, Raspberry Pi and the likes over the Internet.
  You can easily build graphic interfaces for all your
  projects by simply dragging and dropping widgets.

    Downloads, docs, tutorials: http://www.blynk.cc
    Sketch generator:           http://examples.blynk.cc
    Blynk community:            http://community.blynk.cc
    Follow us:                  http://www.fb.com/blynkapp
                                http://twitter.com/blynk_app

  Blynk library is licensed under MIT license
  This example code is in public domain.

 *************************************************************
  This example runs directly on NodeMCU.

  Note: This requires ESP8266 support package:
    https://github.com/esp8266/Arduino

  Please be sure to select the right NodeMCU module
  in the Tools -> Board menu!

  For advanced settings please follow ESP examples :
   - ESP8266_Standalone_Manual_IP.ino
   - ESP8266_Standalone_SmartConfig.ino
   - ESP8266_Standalone_SSL.ino

  Change WiFi ssid, pass, and Blynk auth token to run :)
  Feel free to apply it to any other example. It's simple!
 *************************************************************/

/* Comment this out to disable prints and save space */
#define BLYNK_PRINT Serial


#include <ESP8266WiFi.h>
#include <BlynkSimpleEsp8266.h>

// You should get Auth Token in the Blynk App.
// Go to the Project Settings (nut icon).
char auth[] = "dpbFDqXxOVCz70TOH4lHnLVHw5atsB6G";

// Your WiFi credentials.
// Set password to "" for open networks.
char ssid[] = "Feghaly";
char pass[] = "Password143";

void setup()
{
  // Debug console
  Serial.begin(9600);

  Blynk.begin(auth, ssid, pass);
  // You can also specify server:
  //Blynk.begin(auth, ssid, pass, "blynk-cloud.com", 80);
  //Blynk.begin(auth, ssid, pass, IPAddress(192,168,1,100), 8080);
}

void loop()
{
  Blynk.run();
}

Try changing your Blynk.begin statement to this:
Blynk.begin(auth, ssid, pass, "blynk-cloud.com", 8080);

If that doesn’t work, but it’s working fine via a mobile hotspot, then your ISP is blocking the Blynk traffic.

Pete.

i tried searching the blynk commnity and found a lot of solution and none are working wich your solution is listed too.
if my isp is blocking the blynk traffic how could i solve the issue?

Either talk to your ISP, or change to a different one.
You’d obviously need to know in advance that the new ISP wasn’t going to do the same thing, so maybe try a friends internet to see if they have the same issue?

Pete.

i contacted the ISP and told me there is nothing wrong with the blynk traffic

The way to test it for sure is to reboot your router and try a simple sketch that gets the time from a network time server, then use the same device and connection to attempt to connect to Blynk.

You can read this topic for more info about issues that one person was experiencing…

Pete.