Connect local server to internet(WAN) without ssl?

Hello i heve a question . Is it posible to have an acces to local server trought the internet with using 9443 port withoth ssl certificates ?
I stardet local server and it iss working normal but ssl certificates isnt installed bug it is still working in my local net but when i am trying to connet from outside of my local network it doesnt work !
I am using ddns no ip with hostname forwarded ports and it doesnt help. Maybe the problem is no installed certificates ssl ?
As i know 9443 use ssl but how it works in local net and doesnt in wan !?

1 Like

3 posts were split to a new topic: SSL Connection to Cloud Server

@daniil You don’t need to have a certificate installed on your local server to be able to access it remotely.
I don’t have a certificate installed and it works perfectly well for me.

Do you have a static public IP address?
If not then you’ll need a DDNS service and an updater running on your network.

In either situation, you’ll need to have port 9443 forwarded to the IP address of your local server.

In the app, you’ll need to put either your static public IP address, or the url of your DDNS service in the custom server properties, along with port 9443.

If you’ve done all of this (and don’t have a static public IP) then maybe your ISP uses Double NAT. Have you checked this?



Can you please share the settings you use on the server, also what port should i be using on my code (in Arduino IDE, 8080 doesn’t work)

I have a free hostname form No-IP and I have installed and forwarded port 9443 to my local server. I can confirm that using can access the server admin page so I know that I have access to server externally.

I can also log into the Blynk Legacy app on my android phone using the same external hostname and port 9443.

However when I use:

Blynk.begin(auth, ssid, pass, “”, 8080);
I cannot connect to the server.

If I use:
Blynk.begin(auth, ssid, pass, IPAddress(192,168,1,123), 8080);
I can access the server.

Can you help please!

If your a device is inside your local network then

Is the correct approach.

If you want to use your device outside of your local network then you’ll also need to set-up port forwarding on 8080 as well.


Thanks you so much for the fast response, worked like a charm, was just wondering what is the latest version of blynk library i can use in Arduino ide before getting template error msg, currenylu using 0.6.1 on ide. If i use the latest one i get the error msg
Please specify template id and template name, is there any workaround on this for legacy?

Thanks again!

0.6.1 is the latest legacy library version. You should stick with that one, combined with Blynk local server version 0.41.17


Thanks for the info!