BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Compile error. Believe me I have searched [SOLVED]

Frustrated first time user. 4 hours in and much searching but I still can’t fix the error below.

I have deleted old blynk libraries and examples and installed brand new ones.
I have installed the latest Ardruino IDE.
I do have the latest libraries for everything (according to the IDE)
My NodeMCU definitely works.

The error is below. From googling and searching this forum it isn’t unusual (can that suggest Blynk install instructions needs improving/updating perhaps) however I am yet to get past this compile error…

In file included from C:\Users\alan\Documents\Arduino\libraries\Blynk\examples\Boards_WiFi\NodeMCU\NodeMCU.ino:42:0:

C:\Users\alan\Documents\Arduino\libraries\Blynk\src/BlynkSimpleEsp8266.h:18:21: fatal error: version.h: No such file or directory

#include <version.h>

                 ^

compilation terminated.

What version of the Arduino ESP Core have you installed?

Pete.

Thanks Peter. I have now solved the problem. I hope this helps others.

I went into Tools -> Board -> Boards Manager .
Search for esp8266

I already had it installed, version 2.3.0 (interestingly the same version in the screen shot in the tutorial at http://help.blynk.cc/en/articles/633760-install-esp8266-core-for-arduino-ide )

I updated to the latest version 2.6.3

And problem solved.

Thanks