BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Cloud connection / server blocked from the Middle East?

server
esp8266
#1

First post on the forum so - Hello! . I’m brand new to blynk (and loving it so far), though I managed to get it working fine with Arduino UNO + ESP8266 . One of the biggest snags I’ve hit is the cloud connection.
From the beginning, while registering the account on the Android app, I had problems connecting to your server. Since many web services are blocked here in the UAE, I figured VPN will be the solution and it worked fine. The same thing happened when connecting to the cloud through the ESP. Had to route it through the VPN as well to get it to work.

Not a big deal, however occasionally even with the VPN on (router has a fixed VPN connection), I see that ESP is trying to redirect to an IP address and keeps sending the token but without any response (same behaviour occurs when VPN is off). Perhaps I’m missing something here .

Is there any way around using vpn ? Changing ports / servers ? I’ve seen that there’s quite a few members of the community from the region so maybe someone came up with a solution.
Apologies if it has been discussed before - couldn’t find it in the search results.

0 Likes

#2

Hi

i don’t think that Blynk server will get blocked , i am in KSA which is also known that sometimes blocking servers but never have an issue.

i suggest you to test this first if you are using windows PC star t> CMD > write “ping blynk-cloud.com
as below image

if you get an answer that means the server is not blocked

test and update an i will try to help as i could

0 Likes

#3

Thanks for the answer. Should have mentioned that earlier - pinging blynk-cloud.com works fine. So does the primary website forum etc. It’s just the cloud server(s?) which seem to be somehow blocked. Checked that on multiple different wifi’s (the same provider though) and 4g (different operator though they’re all government owned). That’s why it’s so confusing. Also set a DMZ on the router to make sure nothing gets blocked on the ports side. Plus it doesn’t explain the app not working.
Didn’t have time to run through the blynk files and router logs - is that the only address that the app and esp are trying to connect with ? Again, everything works great through the VPN.

0 Likes

#4

Ok another test you will need the server ip which appears in the last command screen

start > powershell
use the command below and change the server ip in place of
and port in try port 443 for app connection to server and 80 to hardware connection to server

Test-NetConnection -Port <443> -ComputerName <server ip> -InformationLevel Detailed

you should get screens as below

0 Likes

#5

the server ip which appears in the last command screen

You mean blynk-cloud’s ip ? tested. good reply on both ports, working fine.

edit: another interesting thing happened. Once the hardware is running completely standalone, disconnecting VPN, does not effect the server connection in any way - still working fine. However, resetting it, kills the connection until the VPN is up and running again!
Phone app will not work without vpn no matter what though. Completely puzzled now. :exploding_head:

0 Likes

#6

very strange , i run-out of ideas i hope somebody will have a solution for your issue

0 Likes

#7

And here we go again. Was working fine for the past 11 months. Question for UAE or ME based Blynk users : Is anyone having problems accessing the App / Server / website for the last couple of hours ? Took it up with the internet providers but they don’t know what’s up. Works fine on VPN only. Any ideas?

0 Likes