BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Cloning project fails

Hi

I’m using blynk server 0.41.0 and latest android app and ios app

Both apps generate an appropriate QR code for cloning function but it fails to read; saying “not a valid blynk QR code”.

My project is large (i.e. has many widgets) but I don’t believe that is an issue (unless advised otherwise ;-))

I have tried generating codes from both IOS and Android app and alternatively trying to scan 2d code from each with no success.

any clues as to why it might be failing ?

  1. Be sure you are creating a cloning QR, not sharing QR (I know, you are probably well aware of that :stuck_out_tongue_winking_eye: )

  2. I think I recall something about size limitations way back when… whether or not that got resolved I cannot recall. But my largest project seems to clone and scan OK with LS 0.41.0 and even using the beta App.

You could try sending the QR via PM and I can test it.

Hm. @BlynkAndroidDev do you know what that may be?

Definitely creating clones.
I’m stumped why it does not work.

I was investigating last night and seemed to have resolved the issue.

I found in server.properties that my user.dashboard.mac.size.limit = 20 and I already had 20 dashboards in my user profile. Interestingly I did not receive the"max dashboard limit" error message in both my IOS or Android Blynk apps; which should be shown when I try to scan an addition dashboard and I have hit my limit is my understanding.

2 Likes

We’ll fix that, thanks!

I just tried it 2 days ago and the app refused to recognize the Clone QR code

the QR is recognized and decoded by the IOS App

This whole mechanism with the QR codes is broken and stupid

dfplayer-clone

blynk://token/clone/O2IxXourJX1ANgDFRht8oqvO-Ikt6Mki?server=blynk-cloud.com