Cloned Template does not send Push Notification


I’ve just duplicated an existing template, set all the events just like the old one, etc.

All the devices under the old template are working normally, e-mail and push notifications are ok. However, in the the cloned template (100% same configuration as the old one) only the push notification is not working (timeline and e-mail works). I did many trials already with no sucess.

Blynk V1.7.2 (102)
Android 12 (UI 4.1)
Samsung S22

Old Template:

Cloned Template:

BTW.: The event with e-mail and push notification disabled are intentionally configured like this…


What events are you using in the cloned template? Info, warning, critical, content?

Hello @Oleksii-QA

I’m using Info, warning & critical.

I just tested now again one event with the 3 types above with no sucess. Push notification does’nt work in the cloned template.

@Oleksii-QA @BlynkAndroidDev

Did you find any bug related to my reported issue?

My customers are still complaining about it.

@Hugo-BR Hello,

Please need more information.

  1. What server are you using?
  2. And how do you trigger events? With using hardware?

Sorry, we are still investigating it.

Hello @Oleksii-QA @BlynkAndroidDev

A few more inputs from my side:

Server: ny3
How are we triggering? ESP32 → Blynk.logEvent

We did more trials with the cloned template, and we figured out that: If we disable:


Push notifications in the app start to work again.

We also tried to enable, in the app, everything related to this option in order to see if the problem would be related to app side (settings), but it did not worked either.

App → Settings → Critical Notifications:
Critical Notifications [ON]
Ignore Background Resctrictions [ON]

App → System Settings:
Allow Notifications [ON]

Device → Notifications Settings:
Enable Notifications [ON]
Ignore do not disturb [ON]

Can you please check from your side?

@Hugo-BR hm, so it is not all the pushes, just about critical ones? I have Samsung with android 12/13 on my side, I will check on them.

Nop. @BlynkAndroidDev This function, when enabled, is blocking ALL push notifications. In any case, I will double-check it again…

1 Like

Wow, so If it is enabled for one of the log events in a result all log events notifications are not being received?

@BlynkAndroidDev Maybe I was not clear in this point, but this function enabled is blocking the own event push notification itself, regardless if it set as critical, warning, info or content… but in my case, all events had this option ON, so all push notifications stoped working.

1 Like

Thanks, we will recheck critical notifications. I see that you had turned On critical notifications on the smartphone, and it still hadn’t worked.

It seems I’ve reproduced the issue. It will be fixed in the 1.7.4 build. Currently, we are roll-outing 1.7.3 version, so I will upload 1.7.4 right after 1.7.3 will be fully released (probably in several days)

@BlynkAndroidDev Thanks for the feedback.

I did the double-check with different event types (info,warning, critical) and in all of them we have the same issue with this function enabled (it kills the app push notification of the particular event regardless the event type).

By the way, will the reported bug of small symbols be fixed as well in 1.7.3? Symbols too small after last update - #3 by Hugo-BR

1 Like

It should be fixed.

1 Like