BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

CC3000 issues


#1

I have the Adafruit CC3000 breakout setup to an Arduino Uno. It works for about 30 mins to an hour and than stops working. If I reset it, it works again (then hangs again after the ~30mins). Any thoughts?


UNO with WIFI Shield CC3000/Keyes works for some hours and disconnects
Hardware supported by Blynk
Issue with Arduino Uno Rev. 3, CC3000 WiFi and Blynk
TinyDuino hanging after 2 seconds of execution
#2

I sometimes have same issue with Wicked Wildfire. There are similar reports from Spark Core users. It seems to be a CC3000 bug. We would like to collect more reports and then initiate fix request.

Since Blynk is running for weeks on UNO with Ethernet, I really believe that it’s a hardware questions, not the library.


#3

I have the Adafruit CC3000 breakout setup to an Arduino Meg with same issue.
For whatever reason it won’t stay connected for extended periods of time and is random when it drops out. Simple reset and its working again for the next random time period before it drops connection. Signal strength to the router is fine so that is not the issue.

Maybe users having this issue can see if there is any correlation to the widgets frequency setting in the Blynk App.

Thoughts?


#4

First of all, please update CC3000 to Version 1.14.
More about this here
While it is working, even with this update we experienced some stability problems.

According to my tests, CC3000 doesn’t handle bursts of messages :frowning:
I was able to send/receive 10 msgs/sec uniformly distributed in time (compared to 300 with Ethernet shield!).
But if it gets a burst of messages it hangs.
Can someone approve this? Did you experience it with other projects?

Please keep posting your observations. Thanks.


#5

HI. I am trying to run the PushData example to update virtual pin 5 every second with the current run time millis() from a TinyDuino and a TinyShiled WIFI. On my original post here, execution only lasted 1-2 seconds after successful connection to the Blynk server.

After upgrading the firmware to version 1.14, the execution is now lasting 3-4 seconds after connecting to the server but still hangs. We tried disabling the arduino serial output but didn’t help.

Any ideas on what else we can try?


#6

Hearbeat timeout

with the following program I get after 3 to 5 seconds a Heartbeat timeout, then it reconnects (see below)
when I press the buttons about twice a second it works …

hardware: Arduino UNO / Adafruit CC3000 shield
--------------------------- from the lib/example, added a RGB LED ------------------------------
#define BLYNK_PRINT Serial // Comment this out to disable prints and save space

// These are the interrupt and control pins for СС3000
#define ADAFRUIT_CC3000_IRQ 3
#define ADAFRUIT_CC3000_VBAT 5
#define ADAFRUIT_CC3000_CS 10

#include SPI.h>
#include Adafruit_CC3000.h>
#include BlynkSimpleCC3000.h> // library of 18.05.2015

/* ---------- serial output -----------------
[0] Blynk v0.2.1
[1643] Connecting to myWiFi…
[13438] Getting IP address…
[13996] IP: 192.168.1.121
[13997] GW: 192.168.1.1
[13998] DNS: 192.168.1.1
[13999] Looking for cloud.blynk.cc
[14064] Connecting to 45.55.195.102:8442
[14905] Ready!
[34475] Heartbeat timeout
[35729] Connecting to 45.55.195.102:8442
[36589] Ready!
*/

/* see how to connect the LED -> make 3 pushbuttons on the iPhone
green = D4;
red = D6;
blue = D7;
*/

char auth[] = “myToken”;

void setup()
{
Serial.begin(57600);

Blynk.begin(auth, “myWiFi”, “myPass”, WLAN_SEC_WPA2);
}

void loop()
{
Blynk.run();
}


#7

Any news on this? The firmware upgrade only gets me 4 seconds of connection before it drops.


#8

I updated the adafruit CC3000 firmware to 1.14. I uploaded the new cc3000 blynk sketch last night and it is still running the next day in the afternoon. To see that program hasn’t hung up, I added the blinking of an led to indicate the status. I am unsure if this has any affect on the ability of the sketch to not hang, but it is worth noting. Also, I uploaded the sketch using the Arduino IDE version 1.06. It seems promising that everything is still working 20 hrs straight. I will add if anything else changes. Code:

#define BLYNK_PRINT Serial    // Comment this out to disable prints and save space

// These are the interrupt and control pins for СС3000
#define ADAFRUIT_CC3000_IRQ   3
#define ADAFRUIT_CC3000_VBAT  5
#define ADAFRUIT_CC3000_CS    10

#include <SPI.h>
#include <Adafruit_CC3000.h>
#include <BlynkSimpleCC3000.h>

#define LED 7

// You should get Auth Token in the Blynk App.
// Go to the Project Settings (nut icon).
char auth[] = "xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx";

void setup()
{
  pinMode(LED,OUTPUT);
  Serial.begin(9600);
  Blynk.begin(auth, "wifi_ID", "wifi_PW", WLAN_SEC_WPA2);
}

void loop()
{
  digitalWrite(LED,HIGH);
  delay(50);
  Blynk.run();
  digitalWrite(LED,LOW);
  delay(50);
}

#10

My problem with the TinyDuino freezing seconds after starting transmission of data using the PushData blynk example turned out to be caused the use of the SimpleTimer.h library.

After disabling this timer implemented in the example and using a simple delay(500) function to achieve the same effect I got no problems with the execution stopping.


#11

I’m going to test your sketch overnight and see if I have the same results.
Will post findings.


#12

My blynk sketch is still running strong two weeks later. I haven’t added any changes


#13

I have had one timeout so far but will continue to test and not sure if that was something I did or I can replicate.


#14

vteeds, your sketch does seem to run without dropout so that is very good news!

However, now I noticed if I add an analog input widget (A0) then the system hangs.
See if you can replicate that issue.


#15

Any new updates?
I’m having the same problem with cc3000…

thanks!


#16

i’ll check it again but CC3000 is known as very unreliable chip…


#17

hello, I have a CC3000 shield and an Arduino UNO R3; I’m having a big problem with PWM pins; if I use PWM pins (using analogWrite or digitalWrite and using it by app (buttom, slider, joystick)) Arduino UNO crashes and do not return online (monitoring it via serial monitor, is online, but the app say “Arduino UNO went offline”). Using another pins (only digital and analog) cc3000 works without any problem. I also tried using virtual pin (reducing reads and writes).


#18

I hope you are not using the pins that are booked by the shield…


#19

effectly on the last test (reducing reads/writes) i’m using pin 3 :stuck_out_tongue: … THX a lot!


#20

I have the sampe problem with “Heart beat time out”, but when I use a shorter LAN cable, there is no “heart beat time out”, it can run day by day without hung.