Can't set timer widget to 12:XX PM (Can only do am)

I was playing with the timer widget this afternoon and it seems that I can’t change either the start or end time to 12:Anything PM- only AM. I can SOMETIMES get it to stick on PM, but when I go Back to the main widget dashboard, it goes back to 12:XX AM. If I change the time to a number other than 12 (haven’t tested them all), like 1:01, I can change from AM to PM. I’m using Android.

Thank you for reporting. It is already fixed. Will be available in next release.

1 Like

@zeeko Could you please verify it works for you in latest build?

@Dmitriy still not working after updating the app- it’s the same problem.

Ok. Thank you for testing.

Tried the latest Android app last night.

I normally have my Android set on a 24 hour clock but if I change it to AM / PM settings I can’t select 12:XX either.

The other issue is that there is no 00 hours available in AM / PM mode so you wouldn’t be able to set the time at 00:30:00.

I think the timer was designed for a 24 hour clock because in this mode all times are available with 23:59:59 correctly rolling over to 00:00:00.

@zeeko @costas


i’ve found why this happens, but i have not time to fix it now. we are preparing a huge update, which will be released by the end of next week, and it will be with a fix for this issue.

sorry, for this inconvenience - on next week it will be fixed

1 Like

timer should be fixed in last builds

@BlynkAndroidDev looks ok at this end now with clock set in AM / PM mode, thanks.