Can't see my readings on my template

Hello, everyone! I’m new here so hi once again!
I had a doubt, I’m using Node MCU ESP 8266 and MQ 135 gas sensor as my hardware components. I aim to send my sensor readings to my Blynk template, but I can’t seem to do it. I always get an error - exit status 1
I’m tried everything, from changing my USB cable to install the CH9102 driver. I still can’t get rid of that error. For reference, this is my code, I tried to keep it simple -

#include <BlynkSimpleEsp8266.h>

char auth[] = "Token"; // Enter your Blynk authentication token here
char ssid[] = "WiFI"; // Enter your WiFi network name
char pass[] = "Password"; // Enter your WiFi password


void setup() {
   Blynk.begin(auth, ssid, pass);

void loop() {
   float gasValue = analogRead(GAS_SENSOR_PIN);
   Serial.print("Gas Value: ");
   Blynk.virtualWrite(V5, gasValue); // Send gas value to virtual pin V5 on the Blynk app
   delay(1000); // Adjust delay as per your requirement
Can someone pls help me out with this ?

@Spidey Please edit your post, using the pencil icon at the bottom, and add triple backticks at the beginning and end of your code so that it displays correctly.
Triple backticks look like this:

Copy and paste these if you can’t find the correct symbol on your keyboard.


@PeteKnight Thank you so much for looking into this, I’ve done the necessary changes. If you have a sec, could you give me a hand figuring out where I might’ve gone wrong?

If this is your full sketch then you’ll be getting a compilation error message that says “#error “Please specify your BLYNK_TEMPLATE_ID and BLYNK_TEMPLATE_NAME” before you get the “exit status 1” message.

Posting your full compiler message (as text, with triple backticks) will help identify the issue.


   39 |     #error "Please specify your BLYNK_TEMPLATE_ID and BLYNK_TEMPLATE_NAME"
      |      ^~~~~
exit status 1

Compilation error: exit status 1```   
this is all that I get, and even when I change the code and write the template id and name I still get the same 2 errors

Read this…


i tried following these steps, but i am still facing the same issues.

@PeteKnight I saw one of your previous interactions with a member and they mentioned using the previous version of Blynk, I was able to connect my device. Thank you so much for your help !!! Really appreciate it!


I don’t understand your response.
Are you using Blynk Legacy with a local server?
If som which Blynk library version are you using?