Can't get it working with USB

Hello everyone,

I learned about blynk and I tried to run an example to see it working. I ran the script with the Arduino IDE and manually with cmd. When I upload the Arduino_Serial_USB code into my Arduino mega the Serial monitor output shows nothing but my Auth Token over and over again. In my iPhone the app shows that the Arduino is offline.

The script output is:

Ensure that Serial Monitor and Plotter are closed when using this tool.
It uses same port and speed as Serial Monitor

Connecting device at COM3 to
OpenC0C("\\.\COM3", baud=9600, data=8, parity=no, stop=1) - OK
Connect("", "80") - OK

Serial communication can only be used for one thing at a time… so the USB link requires use of the primary Serial/programming port on the Arduino. As mentioned in your script output… do not open the Serial Monitor otherwise you are actually interfering with the link.

Make sure you are using separate Serial ports (AKA Serial1, Serial2 or Serial3 on the Mega) for debugging and any Serial.print() feedback. You will also need to use a TTL-Serial adapter and a different form of Serial Monitor, I use Termite)

But even if I don’t open the serial monitor, it still shows the Arduino as offline, I also tried this code
but no success

Well, you didn’t clarify all your steps, so I am assuming they are as follows…

  • Using the correct COM port and BAUD rate in the USB script (on the PC)

  • Identical BAUD rate set in the device script

  • Keeping the USB script (AKA DOS box or terminal window) open the entire time

  • Not using any other device or serial action with same COM port

  • Correct Auth code used… refresh and double check with new one if necessary

  • Might be possible that your AntiVirus/Firewall might be interfering with the USB-link connection?

  • Try another COM port and or USB cable

  • NOTE: the example sketches may not be properly coded for your precise setup… they are not a guaranteed-to-work example :wink: Some coding experience might be required.

I also highly recommend the TTL-USB adapter (get one, you will probably uses it for other things as well) and the aforementioned other serial monitor option so you can get better debugging.

Searching this forum for other USB-link topics might provide other insights, as this is not the first time someone has had this type of issue.

The USB script was not open the entire time, that was the problem. Thanks a lot Gunner, it’s now working properly.

1 Like