BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Can't connect to blynk app on my phone with wemos d1 mini pro (external antena)

Yes, I use the D1 Mini Pro, they work fine.
You say:

In your photo, the zero ohm resistor hasn’t been moved, so attaching an external antenna will make absolutely no difference - the built-in antenna (the white ceramic thing with “Rainsun” written on it) is what’s being used.

Pete.

1 Like

Sure! they are the obvious choice, when an external antenna is needed. And as @PeteKnight had pointed ONLY THEN the 0ohm resistor needs to be MOVED (or replaced with simple solder shunt)

And your issue… I don’t know. It connects to WIFI, obtains IP, and then can’t reach host. DNS issue??

When I look closely at the circuit board near the antenna and do some tests with my ohmmeter, it seems that the antenna is isolated from everything else. So removing 0 ohm resistor will desable internal antenna but not sure it’s enough fot activating external intenna. Don’t we need to connect the 0 ohm resistor or some jumper to extenal antenna ?
So thank you for these clarifications but first of all and whatever the antenna chosen i should be able to connect to blynk. Isn’t it !

Hi,
Where do i find this information ?

No, it isn’t. The 0 ohm resistor is a kind of switch. Look closely one more time.

Look at this post:

Pete.

In this screenshot, it is 2.3.0

Look under board manager in the Arduino IDE.

https://iotguider.in/wp-content/uploads/2017/08/ESP8266-in-Arduino-Boards-Manager.png

Ok Pete, that’s what I thought we had to do and that matches my ohmic readings. Thanks.

Arduino IDE 1.8.9 beta
ConnectThings_ESP8266 version 0.0.1

Blynk version 0.6.1

@zener In Arduino IDE choose:
Tools/Board/Boards Manager.
Scroll down towards the bottom of the list and find “esp8266 by ESP8266 Community” and tell us what version you have installed.
If it’s anything higher than 2.4.2, downgrade to 2.4.2 and recompile/upload your code and tell us what happens.

Pete.

1 Like

I downgrade from 2.5.2 to 2.4.2

Always impossible to connect to blynk cloud with d1 mini pro

Have you tried to open port 80 of your router?

Looks like you are connecting to your router via WiFi OK, but not actually getting traffic out to the internet.

Edit: Also maybe just try to reset your router? (Off, back on again - not settings :wink:)

And just changing board from d1 mini pro to d1 mini !

If it’s ok with d1 mini (not pro) board, it means no problem with port 80 i presume ?

Port 80 is open.

Oh un Français :wink:

Ah, yes of course - silly me :crazy_face:

1 Like

No, thanks for looking for a solution to my problem

1 Like