Cannot upload (OTA) new firmware

I am trying to upload new firmware to 2 devices. Both devices are identical (Arduino Nano ESP32) and the code getting uploaded to both MCU’s is identical. One uploads fine, the second is giving this error …

“firmware type mismatch” … I have tried uploading the new firmware with “no conditions” under “APPLY UPDATE IF THE DEVICE HAS”…

I am using Arduino IDE 2.2.1, Macbook Air (Big Sur 11.07.10)… I can provide code if you’d like BUT my code is horrendous (im embarassed to show) and my approach and uploads has been working fine between the two devices until today??

EDIT: both devices are showing as online and receiving uploads from the same exact access point as well.


The “firmware type mismatch” error message isn’t something that can be overridden with the “no conditions” option.

The “Apply update if the device has…” options relate to firmware versions, firmware dates etc. the message you are seeing relates to something else.

It’s usually caused by the device and the firmware having different Template ID’s. Is this something that you’ve checked?


1 Like

@PeteKnight … OH GOSH! You nailed it… I will mark this as solved. I thought i was being careful when opening sketch files for the 2 devices. I was not


1 Like