BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Cannot share project on iOS

ios

#1

I know this has been posted a few times before, but the issue remains. I am having exactly the same problem, I cannot share the code between two iPhones with the latest iOS 12.1. It keeps saying: cannot load project. I tried many many times


Sharing Project between Android and iPhone
#2

As what? Your issue may or may not be different… but compared to nothing, this statement doesn’t help any :wink:

Local or Cloud server?

Your screenshot doesn’t even show a QR, of course it can’t scan it…

Eg. it should look something like this… (I just grabbed some random Blynk QR and tried to scan it from my iPhone… so that is probably the reason for the error on my image… or becasue I am currently using the BETA app)

And just to clarify… you are Sharing, not cloning… and if Sharing, you are scanning the QR from the login page, not the new project screen in the App.


#3

Gunner: I am using a “local” server. At this point it does not matter much anymore, I just logged in the other iphone using the same user ID and password, so all is good. Of course, that is not what I prefer, in the mean time, it works .
Just to clarify, I tried to share just the way you described it, not cloning, and that part is not working.


#4

OK. I tested with Local server as well… but was using the Beta version of iOS App.

My old iPhone 4s wouldn’t display any QR with more than 2-3 widgets in it… otherwise it just showed a white box, and wouldn’t share it via any other option.

But if just a few simple widgets then it did dahar OK (but I had to use a Android to scan the share).

I also was totally unable to scan ANY shared QR codes with my iPhone… however my error was as shown above… so also different than yours.

Not sure if any of what I ran into is indicative of an Sharing issue with the iOS App or just my old phone :thinking:


#5

Gunner:

Certainly is different than what I get. This is what I do: Using the iPhone XS MAX I turn ON share access, the generate link becomes active, so I generate the QR, and the QR looks good, not red warning whatsoever. Next I open the Blynk app on the other iPhone X, before doing anything else like longing, etc., I tap the scan icon at the button of the screen, the iPhone X camera is activated, and I point it to the iphone XS MAX showing the QR, and this what I get on the iphone X : cannot load project. Also I have an iphone 7plus , same result.


#6

It would be good to have the ability to paste in a URL Instead of trying to debug how QR scanning works. IMHO.

I am new to Blynk but my friend is trying to share his project to me using the QR code and I am having nothing but problems and there seems to be no workaround to solve it.

As a courtesy to the end-user the QR scanning should be fixed but if time is short all the time since 2016 apparently, then how hard would it be to put in a text field so that people can use RedLaser to scan the QR code and then paste in the URL.

Humble suggestion hear but my first impressions are not great because of this hangup with QR code scanning


#7

As I understand it, the QR sharing option was only meant as a simple demo during the initial stages of Blynk development. And it has worked nicely for the most part. I suspect recent changes in development (to all the other more commonly used aspects of Blynk) have led to the recent sharing issues, with iOS at least…

Patience, they can only work so fast (or try Android) :stuck_out_tongue:


#8


#9

+1 to the invalid QR code error on iOS 12 with 2.23.0. I’m trying to share my project from Android using Blynk 2.27.0. Probably caused by the differences between 2.23 and 2.27.


#10

QR is not so important. I’d Much rather explore “Blynk”

I suggested putting in a text field option in Blynk as an alternate to QR.

QR is not working.

The “cool” factor of QR codes is long gone, and I’d guess this community has wasted 30 man hours talking about QR.

I have seen many failures - so I put the time here on this topic for the sole purpose of helping the project.


#11

I seem to recall there used to be a link included at one time (in the shared email), but I think issues with which Cloud Server held the data vs which Cloud Server ran the receiving App, Geo-DNS and even Local Server cross connection issues prevented that from working as well as the straight QR code did

We noticed :smiley: Well, at least recently for some use cases. Across Android it seems fine. “there is known issue of Android -> iOS compatibility of sharing QR codes. Will be fixed soon

But it will get fixed, just like other issues as development moves forward… eventually… perhaps… (heck, I am still awaiting getting the proper scaled fonts back :stuck_out_tongue_winking_eye: )

Since the community does not do the actual developing of Blynk, discussing it is not wasted time :slight_smile:


#12

On my opinion, its not the cool factor which makes the QR code necessary, but the convenience it gives me by letting me share my project with another phone without typing long obfuscated URLs. I think the root of the problem is probably not the code itself, but the fact there were breaking changes between the two versions of the android and ios app and that’s why the latter cannot read it properly.


#13

Of course QR codes are great. I’ve never seen an instance where they did not work - until this situation

UPDATE: The workaround solution was to give my friend my account login details and let them login to my account on their devices and Set it up. Then I logged back into my account on my iPhone and I got to see is working demo. This was the main goaL. I was impressed with the quick work my friend accomplished using Blynk. He made a nice little sensor status report with histograms of data


#14

Maybe I should try this method, but obviously its not suitable for everyone since it gives full control over your project.


#15

Actually it doesn’t, I am the user wanting to see the Blynk project but cannot get QR to work. My friend is the project maker and I gave him my account, which was a fresh account.