Cannot regain access to ESP32 app

I’m in deep! :slight_smile:
I recently built a simple circuit with an esp32 board and an 8 relay board for a friend.
I managed to get it working ok and then I tried to give it to transfer control to my friend.
I didn’t know the “right” way to do so this is what I did:

  1. I had him download the Blynk app on his Android phone and get an auth code. I updated the Arduino sketch with this new auth code and wifi details (his phone’s hotspot) and downloaded to the ESP32. When we tested it, it’ wouldn’t go online on his app, so I tried on my phone and I had control, although the auth code and wifi details were now different!
  2. I deleted the project on my app and logged out, hoping to release the board for him. It didn’t work. Still offline.
  3. I tried to log back in on my app but it seems I forgot the password (though I am quite sure it’s good). So I pressed “forgot password” but didn’t get a reset email.
  4. I did a flash erase on the ESP32 with python, made a new account, got new auth code and downloaded to the board. Still no luck…
    What should I do?:((

Is this legacy/old Blynk (version 0.1) or Blynk 2.0?


Hi Pete !I am using Blynk 0.1 version 2.26.7(1). Still no password reset email…

You should have cloned your project and asked him to scan the QR code, then send you the Auth token for his device by email.

I’m guessing that either the updated sketch didn’t upload, or you uploaded the original version of the sketch.

Check your junk mail.


Thank you for you reply, Pete!
I got my password reset email and I managed to log in.

I didn’t know that before…

I think it uploaded because it connected to the new wifi ssid.

Now that I got in, i tried add my 8 buttons again and I can only add 5 before I run out fo energy. Why is that?Is it because my password reset?

That seems to contradict what you said before.

I’m guessing that you actually did the App Sharing option, which costs a non-refundable 1000 energy units. Sharing is designed to allow you (the account administrator) full access to edit the app project and control the device.
People who you’ve shared the app with cannot edit the app project, but can control the device.


Ok, I was refferring to the project not going online, not the board. I have set the blue LED on the board to turn on when connected to wifi and it did turn on when we tested.

Cool, I tried to clone it on my other phone and it works (I can control the relays). But now do I need to edit the sketch and put in my friend’s wifi ssid and password or is his Auth code all I need to change in the arduino sketch?

That doesn’t make sense.

Cloning is a way of providing an unconnected person with a copy of the app, so that they can use their own hardware and sketch in a totally unrelated duplicate of your system.

I think you need to be much clearer about EXACTLY what it is you are doing if you want assistance with whatever problem you are currently experiencing.