Cannot init Blynk + Adafruit Fona 808 on Mega 2560

I have an Arduino Mega 2560 and a Adafruit Fona 808 shield.
In the hardware list I saw this combination should work, but I can’t get it working yet.
When I use the Adafruit test the serial monitor says “FONA is OK” and “Found FONA 808 (v2)” and I can run the test cases like read the sim ID, etc.
So I assume the wiring, available power etc all is OK.
Even though I am using the Mega I am using SoftwareSerial since Adafruit Fona currently does not support hardware serial.

However, when I use the SIM800_SIM900 example code and populate my RX and TX pins it unfortunately does not work.
The serial monitor says

Initializing modem…
___ __ __
/ _ )/ /_ _____ / /__
/ _ / / // / _ / '/
//_, /////_
__/ v0.4.6 on Arduino Mega

[13223] Modem init…
[23439] Cannot init

I have already tried the AT_debug but all baud rates fail and I receive:

Module does not respond!
Check your Serial wiring
Check the module is correctly powered and turned on

Hope someone can help me out from here. Or has perhaps a working example for the Fona 808.

We have some users reported it works OK, however I don’t have such hardware to test with.

What could be a next step for me to get this up and running?
I have tried connecting the Adafruit Fona to all Rx/TX pins on the Mega but neither worked. The AT debug fails on all baud rates.

@oudevolvo I suggest you ask over at the Adafruit forums as this is their product. Once you have it communicating with the Arduino properly, then we can better assist with Blynk.

Thanks, done that.
However, the thing is I got the Fona 808 working with my Mega using the FONAtest sketch and the Adafruit library. It says:

FONA test basic
Initializing… (may take 3 sec)
Attempting to open comm with ATs

Then a couple of
—> AT
And in the end

SIM 808 R14.18
Found FONA 808 (v2)

And then shows the IMEI.
Battery charge is 100% and using that test sketch I can request a URL (and get a response), read SMS messages from SIM.
But let’s see what comes from the Adafruit forums.
Will keep you posted.

To update this topic as well, I’ve got it working thanks to the support via/on Github. For the full story see
In short:

  • I had to change the order of the RX and TX wiring
  • Fona gave an error on command AT&FZE0. Changed it in TinyGsmClientSIM800.h so it outputs AT&F0 instead and now it works
1 Like

Hello, I’m having the same problem with an arduino UNO and a fona808. I tryed to modify the TinyGsmClientSIM800.h file and I switched RX and TX. Do you have any other suggestion?

Thank you for your help!

Are you able to connect to the module using another library or even direcltly via a TTL cable?

I’ve solved the issue, it was just a matter of copying the right files to the right place.

Thank you for the help

1 Like

A post was split to a new topic: Modem init problem with SIM800L