BLYNK
BLYNK.IO       📲 GETTING STARTED       📗 DOCS       👉 SKETCH BUILDER

Cannot create bin file for use with BlynkAir

I am using Arduino IDE 1.8.19. I am compiling a file for a Mega 2560 using ESP8266. When I select the “Export compiled binary” the IDE creates .hex files. Can someone point me to the setting that allow this function to create .bin files. Do I have to do an intermediate step to convert the .hex to .bin outside the IDE? I am hoping there is a simple setting change that I am missing.

create platform.local.txt next to platform.txt and put

## Create output (bin file)
recipe.objcopy.bin.pattern="{compiler.path}{compiler.elf2hex.cmd}" -O binary {compiler.elf2hex.extra_flags} "{build.path}/{build.project_name}.elf" "{build.path}/{build.project_name}.bin"

restart the IDE
then if you use Export compiled binary from Sketch menu, you will find the bin file next to ino file

2 Likes

Thank you for the reply. I did a search of my computer. In my Arduino\Libraries folder I have 239 files named platform.txt in various subfolders. What am I missing?

I figured out which file is being used by reviewing the verbose compiler messages. However I cannot put a file in the folder indicated. The C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.57.0_x86__mdqgnx93n4wtt folder where it is located is locked down. I tried the standard techniques for taking ownership and granting access to the folder. I still can’t add the file to the location in question.

You can find the location of boards packages in Arduino IDE Preferences as the location of the preferences.txt file at the bottom of the Preferences dialog. It is clickable and opens the folder. There find the boards package in packages folder.

Thank you to everyone who posted to assist. I found the solution to the final issue on this link