Blynk server suddenly not accepting my data

Hello, I have a device connected to Blynk since 1 1/2 years. Of course I do upload new code frequently, but I didn’t change anything in the Blynk related lines. My device is a Arduino Mega with an ESP8266 shield, and it was running just fine.
Since a few days, my App doesn’t update data anymore, and showing the device offline. But from the perspective of the device, it is connected to the server as shown by the “!Blynk.connected” command, which I call every time before i transmit and returning an active connection. I can even see on the transmission LED on the ESP, that it is happily doing its job at the normal intervals.
When reseting the system, the initial connection will be acknowledged in the App, but once the first data transmit would start, the App will show the device disconnecting.
Does anyone have an idea what the problem could be?

Thanks and regards!

Not sure what’s causing your problem, because you haven’t provided much information, but it might be a good idea to upgrade to the new version of Blynk, because you are using the Legacy version which is no longer supported and will be fully retired (turned off) at some point.

In the meantime, have you tried rebooting your router?


Resetting routers didn’t help. I will look into the new Blynk then. Thanks!

I fixed the issue, and the problem was dynamic memory.

With my last software update, where I have added a few features (but not touched Blynk functions at all), I have passed the 70% mark on used dynamic memory on my Arduino Mega. In fact, it was initially 78% which gave me as well a compiler warning.
So, after I had installed the previous version of my code and Blynk again worked properly, I then added code feature by feature, until I ran into the Blynk App not updating issue.
I have rewritten all code to save memory and it all works perfectly now.

Is there any explanation why lack of dynamic memory can affect the Blynk Data Transfer? Or is this all just a weird situation?
Nevertheless, I will still try to use the new Blynk too. Does anybody know if the Arduino/ESP8266 (ESP01) Shield combination will still work there too, as now I didn’t see anything like that to choose from?

Thanks, and regards!