BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Blynk server + reverse proxy

Hello,
i have my own blynk server running in docker using the compilation of maxbanton / blynk-server: latest.
I need to log in via nginx reverse proxy to my server.
My ngnix configuration:

server {
  listen 443;
  listen [::]: 442;

  server_name blynk.nahorniak.cz;

  location / {
      proxy_pass https://192.168.1.10:9443/;
  }
}
"
Setting up blynk server:
"
initial.energy = 0
allow.reading.widget.without.active.app = true
user.message.quota.limit = 100
logs.folder = / data / logs
user.dashboard.max.limit = 3
lcd.strings.pool.size = 6
server.ssl.key =
webhooks.response.size.limit = 96
hardware.mqtt.port = 8441
table.rows.pool.size = 100
terminal.strings.pool.size = 25
admin.email=admin@nahorniak.cz
admin.rootPath = / index.html
user.widget.max.size.limit = 20
listen.address =
mail.properties = / config / mail.properties
blocking.processor.thread.pool.limit = 6
stats.print.worker.period = 60000
enable.db = false
force.port.80.for.csv = false
enable.raw.db.data.store = false
restore.host = blynk.nahorniak.cz
contact.email=admin@nahorniak.cz
server.host = blynk.nahorniak.cz
csv.export.data.points.max = 43200
restore = false
user.profile.max.size = 256
allow.store.ip = true
allowed.administrator.ips = 0.0.0.0 / 0, :: / 0
net.interface = eth
webhooks.frequency.user.quota.limit = 1000
http.port = 8080
web.request.max.size = 524288
user.devices.limit = 50
async.logger.ring.buffer.size = 2048
user.tags.limit = 100
server.ssl.key.pass =
admin.pass = admin
hard.socket.idle.timeout = 10
product.name = Gas | nahorniak
data.folder = / data
map.strings.pool.size = 25
profile.save.worker.period = 60000
https.port = 9442
log.level = info
server.ssl.cert =
force.port.80.for.redirect = false
notifications.queue.limit = 2000
notifications.frequency.user.quota.limit = 10

Currently, web administration works, but login through the application does not.

Unfortunately, I did not find any solution here in the forum.

I’m really a beginner, please use the basic instructions / advice.
Thanks…

I really don’t know what to do. Can someone please help me?

If you didn’t advise me, I did it myself.
For those who want to solve it, I have a working but bad solution:
To access the web administration, I use a reverse proxy according to the settings above. For access via the application, I set up portforwarding with port 9443 in the router. The domain that points to the public IP address is written in the application. Then port 9443 is selected. It works, but it’s not through a proxy and therefore so secure for communication.
But if no one gets advice, I can’t do it better.