BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Blynk Server local, no login possible

Hello everybody,
I am looking for help or a idea why I have problems.

I have try to setup the local server on Raspberry pi.

So the installation works and I can start the blynk server on pi and get the feedback that server start and files was logged on…

I’m my router I set the forward ports for blynk.

Then I try the blink app, set to custom, set the ip and let the original port.

Then I try to connect to custom server by default email address and password.

This login do not works.
Also under windows I do cannot login.

Any idea? I thing I have all done what I can read, but I thing there must be a bug in my handling.

Best regards

I forgot… I use the latest Raspian from homage pi, Java 8 and blynk latest. . 15 version.

If your mobile device is connected to the same network as your server (via WiFi) then port forwarding is not necessary.
For the port forwarding to work when you are connected to an external network (or via GSM) then the IP address that you use in the custom setup needs to be your external IP address (if this is static) or the URL of a DDNS server which is set-up to redirect data to your public IP address. This will need an update script running on your home network to keep the DDNS server updated with your current publc IP address.

The port should be 9443

Do you mean admin@blynk.cc/admin ?
You should create a new account and put your email and the password of your choice in there.

What EXACTLY are you trying when you do this, and what results are you seeing?

Pete.

Dear Pete, yes the Port in Blynk app is like you descripe and the access data admin@blynk… and so on are also like you descripe.
So I do all like the doco said and you said.
But the blynk app answers with no connection possible. Try later. I see the ip of the pi in the router and try under windows with https the ip and the port a login, 192.168.1.3:808o or 9443, also with /blynk-login.
Nothing works. It’s curios.

Is your Pi connected via WiFi?
I think the default interface is the one connected to eth0, which may not be one you’re seeing as your router. The WiFi and eth0 interfaces will have different IP addresses.

Some details would be useful!

Pete.

The Pi was connected over Lan, not wifi.
I will despribe tomorrow all I have and see.
So this time is to late, I finish trying for this day.
Best regards and thanks for helping me.

Hello,
so here the details:

Raspberry Pi with SD card and newest OS from Rasperry Org, Webside

Rasberry is on a home Network on one Port of the Router

RJ45 LAN used, not WIFI

Install OS

Install Java 8

Download Blynk Server, server-0.41.15-java8.jar

Test LAN with Webbrowser on PI, works.

Start : java -jar server-0.41.15-java8.jar -dataFolder /home/pi/Blynk

get Feedback: Blynk Server successfully started.
All server output is stored in folder ‘/home/pi/logs’ file.

log file:
09:45:21.506 INFO - Using data dir ‘/home/pi/Blynk’
09:45:42.844 INFO - Region : local. Host : 192.168.1.3.
09:45:57.529 INFO - Initializing gmail smtp mail transport. Username : example@gmail.com. SMTP host : smtp.gmail.com:587
09:45:59.425 INFO - Reports : 0
09:45:59.445 INFO - Didn’t find custom user certificates.
09:45:59.510 INFO - Didn’t find Let’s Encrypt certificates.
09:45:59.519 WARN - You didn’t specified ‘server.host’ or ‘contact.email’ properties in server.properties file. Automatic certificate generation is turned off. Please specify above properties for automatic certificates retrieval.
09:45:59.546 WARN - ATTENTION. Server certificate paths (cert : ‘/home/pi’, key : ‘/home/pi’) not valid. Using embedded server certs and one way ssl. This is not secure. Please replace it with your own certs.
09:47:26.536 INFO - HTTP API and WebSockets server listening at 8080 port.
09:47:26.577 INFO - HTTPS API, WebSockets and Admin page server listening at 9443 port.
09:47:26.595 INFO - Mqtt hardware server listening at 8440 port.

Now I go to Download Blynk to my tablet. with WIFI
The Tablet is in the same Network: 192.168.15

Start Blynk App
Type Log In ( green on left side)
Tap the symbol min the under area
switch to custom
set the IP 192.168.1.3 and Port 9443
tap ok
Type admin@blynk.cc
Type admin
Try Login…
Result : incorrect password or Email adress, please check and try again

If I try with Windows by Webbrowser , on LAN in same Network:

https://192.168.1.3:9443/admin …do not works, no connection possible
https://192.168.1.3:9443…do not works, no connection possible
https://192.168.1.3: …do not works, no connection possible

What I see, or I thing to see, that after some trying login the comes a folder on Raspberry:
Folger name: admin@blynk.cc.Blynk.user
I thing , this folder was not there before i trying to login in. But Ian not quit sure.

{“name”:“admin@blynk.cc”,“email”:“admin@blynk.cc”,
“appName”:“Blynk”,“region”:“local”,“ip”:“192.168.1.3”,“pass”:"
xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx=",“lastModifiedTs”:
1614797925769,“lastLoggedAt”:0,“profile”:{},“isFacebookUser”:false,
“isSuperAdmin”:true,“energy”:100000,“id”:“admin@blynk.cc-Blynk”}

Could this by the Auth Token ? I change for here the Values to xxxxxxxxxx.

Best Regards
Rainer

I’d suggest that you do the following…

  1. check that your server.properties file has an entry like this…

admin.email=admin@blynk.cc
admin.pass=admin

and this…

allowed.administrator.ips=0.0.0.0/0,::/0

  1. delete the admin@blynk.cc.Blynk.user file

  2. attempt to log in at https://192.168.1.3:9443/admin using the username of admin@blynk.cc and the password of admin

Pete.

I do what you recommend mand we go one step further.
Now, with
https://192.168.1.3:9443/admin

I see the green windows on PC, with login fields.
But login was not possible with:
admin@blynk.cc
admin

Sorry, iam not correct .
I delete the file like you recommend, but a server.properties file I do not found.
So I can´t make your recommend Steps for this.
Were I can found the server.properties file on PI ?

Read the instructions here…

Pete.

Thanks, now i creating server.properties file in same folder as server.jar
with
´´´
https.port=9443
http.port=8080
admin.email=admin@blynk.cc
admin.pass=admin
allowed.administrator.ips=0.0.0.0/0,::/0

trying again, but it do not works.
frustrating :-(

I make also this:

https.port=9443
http.port=8080
admin.email=admin@blynk.cc
admin.pass=
allowed.administrator.ips=0.0.0.0/0,::/0

ErrorMessage nin Blynk app:
Incorrect password or Emailadress.

I don´t know, what I should do.
It don´t make more fun.

Did you restart your Blynk server after creating the server.properties file?
Have you followed the steps I provided earlier once you did this?

Pete.

Yes, I do this.
Also the steps you write before.
So frustrating

There must be a reason why I cannot log in.
But I do not found it.
So bullshit… And frustrating

Is this correct in server properties.:

admin.pass=

Or this

admin.pass=admin

I tried booth and nothing works

Is there anybody who has the fitting idea, what could be happen?

So meanwhile Iam one step further.
I can login on Windows and see the dashboard.
Fine.
But with blynk app there comes with the same accout data like in windows login the message
user not registered
?

As I said before, when you are logging-in via the App I think…

Pete.