BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Blynk server and ioBroker on one Raspi 4 1GB dosent work?

Hi @ all,

i am new in the world of Blynk and so forgive me if my issuse is simple or clear.

I have used the search, but coulnd find a topic, that can help me.

I have a Raspi 4 1GB, on this run my local blynk server. thats works fine. i can connect with it and control my wemos D1 mini. Know i installed ioBroker to bulid the bridge between alexa and my Homematic
smart Home.

The installation be done without issues, and both works. ioBroker and Blynk.
after undefined time, the blnky server is down, ioBroker always run. after a reboot both works again.
untill undefined time the blynk server is down again.

so my problem is to figure out why the blynk server shut down.
did anyone had the same or similar problem?
That the server not runing 24/7.

all packes are up to date, i run Java 11.
so if you need more information, please ask.
im not an super programmer so please have a little patience.

Thanks and regrads from Germany

Hello Germany!

Look thru your log files! I don’t have an active (RPI + Blynk) setup at the moment, but generally you’ll find the logs in the directory /var/log. Blynk might put some of its own logs in the directory (or sub dir) where it was installed.

The files /var/log/messages /var/log/syslog and /var/log/kern.log should give you plenty of information.

1 Like

hi, and thx for your answer.

after couples of hours testing and reading the logs, i have no riesen what is the problem.
the only thing i know, after the blynk server get down and i will restart it without an reboot, the following meassage is in the kern.log

May 17 16:09:15 raspberrypi kernel: [59139.063937] Out of memory: Kill process 431 (java) score 139 or sacrifice child
May 17 16:09:15 raspberrypi kernel: [59139.063989] Killed process 431 (java) total-vm:378308kB, anon-rss:107976kB, file-rss:3832kB, shmem-rss:0kB
May 17 16:09:15 raspberrypi kernel: [59139.087013] oom_reaper: reaped process 431 (java), now anon-rss:0kB, file-rss:16kB, shmem-rss:0kB

after a reboot it still runs for hours. i also tested to use monit, but there is no PID file or i dont found it…

If you have time to help, please let me know if i should post some other logs or something.

its a little strange for me ;(

Sounds a bit of a drastic solution, but maybe if you have quite a few kids kicking around the house then you won’t miss the odd one :open_mouth:

Is your Pi set up to allow virtual memory usage?

Pete.

Hello Pete,

Do you mean the overlay file system or the extended file system(raspi-config -> advanced…)?
The extended file system is enabled.
the OL file system is not enabeld

I was meaning do you have virtual memory (swap file to SD) enabled.
Having the swap file enabled will reduce the life of the SD card, but is necessary for most people running a Pi < V4.
Some Pi 4 installations opt to disable the swapfile, because the Pi 4 has more memory, but if you do this and then exceed the physical memory you’ll have a problem.

Maybe installing something like Webmin would help you to monitor memory usage.

Pete.

so i dont aktivate Swap

but when i check the status, swap was aktiv, right?
i killed the process, maybe it will be better ^^

dphys-swapfile.service - dphys-swapfile - set up, mount/unmount, and delete a swap file
Loaded: loaded (/lib/systemd/system/dphys-swapfile.service; enabled; vendor preset: enabl
Active: active (exited) since Mon 2020-05-18 21:28:10 CEST; 57min ago
Docs: man:dphys-swapfile(8)
Main PID: 439 (code=exited, status=0/SUCCESS)
Tasks: 0 (limit: 1599)
Memory: 0B
CGroup: /system.slice/dphys-swapfile.service

Mai 18 21:28:10 raspberrypi systemd[1]: Starting dphys-swapfile - set up, mount/unmount, and
Mai 18 21:28:10 raspberrypi dphys-swapfile[355]: want /var/swap=100MByte, checking existing:
Mai 18 21:28:10 raspberrypi systemd[1]: Started dphys-swapfile - set up, mount/unmount, and
~
lines 1-12/12 (END)
pi@raspberrypi:~ $ ^C
pi@raspberrypi:~ $ sudo swapoff -a
Getötet
pi@raspberrypi:~ $

@PeteKnight

oh today i read your post agin and now i see, i had to check that swap is on not off ^^
i will try again later to aktivate swap again and set the virtuel memory to a size about 2GB.

After I have reactivated the swap function and set the memory size to 1 GB, my blink server is now running
several days without stopping :slight_smile:

1 Like