Blynk RTC example code not compile

I tried to use the RTC widget and RTC example sketch from:
I didnt change anything on the example sketch except the wifi configuration. When I hit the compile button on the arduino, it showed the error and highlighted the row “BLYNK_ATTACH_WIDGET(rtc, V5);”

Arduino: 1.6.10 (Windows 7), Board: “Generic ESP8266 Module, 80 MHz, 40MHz, DIO, 115200, 1M (512K SPIFFS), ck, Disabled, None”

RTC:52: error: 'void BlynkWidgetWrite5(BlynkReq&, const BlynkParam&)' was declared 'extern' and later 'static' [-fpermissive]
In file included from C:\Users\ASUS\Documents\Arduino\libraries\Blynk/Blynk/BlynkApi.h:17:0,
                 from C:\Users\ASUS\Documents\Arduino\libraries\Blynk/BlynkApiArduino.h:14,
                 from C:\Users\ASUS\Documents\Arduino\libraries\Blynk/Adapters/BlynkEthernet.h:18,
                 from C:\Users\ASUS\Documents\Arduino\libraries\Blynk/BlynkSimpleEthernet.h:20,
                 from C:\Users\ASUS\Documents\Arduino\libraries\Blynk\examples\Widgets\RTC\RTC.ino:39:
C:\Users\ASUS\Documents\Arduino\libraries\Blynk/Blynk/BlynkHandlers.h:155:10: error: previous declaration of 'void BlynkWidgetWrite5(BlynkReq&, const BlynkParam&)' [-fpermissive]
     void BlynkWidgetWrite ## pin (BlynkReq& request, const BlynkParam& param)
C:\Users\ASUS\Documents\Arduino\libraries\Blynk/Blynk/BlynkHandlers.h:163:31: note: in expansion of macro 'BLYNK_WRITE_2'
 #define BLYNK_WRITE(pin)      BLYNK_WRITE_2(pin)
C:\Users\ASUS\Documents\Arduino\libraries\Blynk/Blynk/BlynkHandlers.h:382:1: note: in expansion of macro 'BLYNK_WRITE'
exit status 1
'void BlynkWidgetWrite5(BlynkReq&, const BlynkParam&)' was declared 'extern' and later 'static' [-fpermissive]
This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

Anyone have any idea about this error, all other Blynk widget sketch such as Terminal widget run perfectly.
My Arduino IDE version is 1.6.10
My Blynk library version is 0.3.8

complies fine for me but i am using 1.6.9 IDE.

Yeah, I updated to 1.6.10 about 2 days ago and because I never tried the Blynk RTC before so I do not sure is it the Arduino version problem?

im just dl 1.6.10 now so will check it again for you in a few mins…

1 Like

ah shit, it is bjorked for me now that i have 1.6.10 installed!!!


this is going to ruin all my projects!!! revert revert!!!


phew, i am back on 1.6.9 now… RTC example complies fine

1 Like

Thanks for letting us know we shouldn’t move to 1.6.10 @Dave1829

So something wrong with 1.6.10 version :slight_smile:

Any updates on RTC with IDE 1.6.10 yet guys?

I’m bump to the same issue on


and currently doesn’t have any experience to revert back to IDE 1.6.9 … :slight_smile:

You could try 1.6.11 or roll back to 1.6.9.

just DL the 1.6.9 and install it!


I can confirm that using 1.6.9 fixes this problem on the Mac as well.

The latest 1.8.x does not work.