Blynk.notify(message) not working

Hello everyone,

I’m currently using the Blynk library in a project with a local server and a NodeMcu. Everything works fine except Blynk.notify().

Even though I get notification when hardware goes offline (with the Notification Widget), I can’t throw my own notification !

I tried with a HTTPS request: “https://:9443//notify” and it respond with a 404 error.
I also tried with a simple code like:

BLYNK_WRITE(V0) { Blynk.notify("Test"); }
Doesn’t work either.

Hope someone will be able to help me.

Blynk local server,

That’s because making-up commands like that doesn’t work!

My guess is that you’re running one of the beta libraries, but that is just a guess, because despite being asked to provide this information when you created this topic you didn’t.


1 Like

Dear Pete,

I don’t really think that the kind of answer you gave me is supported by the Blynk community and company. I have to say that I don’t really understand the reason of such a condescending answer from you.

I didn’t see the information about giving the library when I posted my question… Is that a good reason for such an arrogance ? I don’t think so.

Also, I let me explain the request I use. It is from the Blynk Api Documentation : Blynk HTTP RESTful API · Apiary
However, when I wrote my question I used “<>” between slashes and the made the text in between disappear (weirdly). So to rephrase, I used: “https://ipLocalServer:9443/authToken/notify” (the same way it is in the documentation).

Finally, after looking at my server website, I found that I’m using the 1.0.0-beta.3 Blynk Library, but I don’t know why this one because I just downloaded it from the Blynk GitHub.

Anyway, I hope we’ll be able to find a solution together by beginning to write to each other respectfully.


Hiding in plain sight…

Before creating the topic

  1. Search forum for similar topics
  2. Check and
  3. Add details :
    • Hardware model + communication type. For example: Arduino UNO with Ethernet Shield
    • Smartphone OS (iOS or Android) + version
    • Blynk server or local server
    Blynk Library version

If you follow the recommendation in point 1 then you’ll quickly find the answer.


1 Like

I keep searching, but I’m not finding anything on how to change the Blynk library in a local server…

It would be the library in Arduino IDE.