Blynk.notify has stopped working after latest iOS update (Particle IDE)

Since updating to 2.20.0 yesterday, my blynk.notify has stopped working. iOS v 10.2.1, blynk 0.5.1 in particle IDE. I have 2 different projects running on Particle Electron both using hologram sims. I have not made any changes to my code in quite a while. The only thing that seems to have changed is the update.


Sounds like you have missed some required Port changes perhaps?

I believe even Cloud Server requires it now… but that should be Automatic, so try upgrading the Library to the latest (v0.5.2) and reflashing your devices… v0.5.1 is sooo February '18 :stuck_out_tongue:

As shown in the release updates for v0.5.2…


And even if not Port related, other issues can happen when not keeping current… so remember to keep ALL aspects of Blynk updated: App, Library & Local Server (if used), not just one or two…

And perhaps update your Particle IDE as well?

@Eugene please take a look.

Thanks for the reply guys. All good suggestions @Gunner. Unfortunately, 0.5.1 is the newest version available in particle IDE. So, as far as I understand your reply, the app is updated, library is not (nothing newer available) and I am using the cloud.

Hopefully @Eugene finds something :grin:

Thanks for your time

1 Like

@Gunner quick update. I did check in the particle IDE and the latest version of the Blynk library 0.5.1 does use port 80 as you suggested.
Thank you

So, is Blynk.notify() working for you now?

No it’s still is not working

Possibly obvious question, but have you reflashed your hardware lately with Particle v0.5.1?

Using cloud server the port 80 should be automatic… but perhaps confirm you didn’t manually have something else… not even sure if that would have anything to do with Blynk.notify() anyhow :blush:

Another Android trick that might work with iOS is completely remove the App and reinstall… and double check any App permissions.

I don’t see any issues on app side…
Please try removing Notifications widget and adding it back.

@Gunner sorry for the late reply. I re-flashed the hardware and confirmed the port setting as you have suggested. I did not remove the app completely but did as @Eugene suggested and removed the widget then re-installed it. Same result, no blynk.notify on the phone.

Thank you

Strange, I have deleted the entire project from my phone and re-built it with an entirely new auth token-results are the same, blynk debug looks fine, blynk.notify is not working.

Go to Terminal (or other console application), and execute following command:

curl -v -X POST -d "{\"body\":\"test1\"}"  "<TOKEN_HERE>/notify" --trace-ascii /dev/stdout -H "Content-Type: application/json"

Check response for error description.

Here are the results

Replace <TOKEN_HERE> with actual your token

One more try: remove “<” and “>” around your token.
HTTP api is described here:

Thanks for the link, apologies for the errors

So the error is “Notification widget is not initialized” which means either there is no Notifications widget in the project or that your system prohibited push notifications for Blynk.

Double check that you have Allow Notifications set in System Settings-> Blynk -> Notifications

Sure, I have done all of that prior to posting. I have not made any changes to my phone or firmware other then doing the latest update then it stopped working.

I have the widget in both projects, I have deleted it and added it back, I have completely removed and rebuilt one of the project apps, I have checked and double checked my phone
-allow notifications is ON
-Show in notification center is ON
-Sounds is ON
-Badge App Icon is ON
-Show on Lock Screen is ON
and Alert style ALERTS is selected.

Just reconfirmed those settings in Settings>Notifications>Blynk on my phone