BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Blynk not connect on WiFI


#1

I am trying to connect to network, My hardware is Arduino Uno + WiFi Shield.

Tryng the wifi code, the console output is still on connecting state:

[82] Connecting to MyNetworkNane
[10117] IP: 192.168.0.214
[21139] Connecting to blynk-cloud.com:8442
[31140] Connecting to blynk-cloud.com:8442

and ready never appears. It seems wifi connection is done but network acces to blynk server not.

If I try telnet by mac terminal to :
telnet blynk-cloud 8442

connected appear:

Trying 139.59.206.133…
Connected to blynk-cloud

My network access is by ADSL router. Do I need any configuration ?


#2

@Domenico_Sicignano repeated Connecting to … messages may mean a bad token.

Did you enter a valid token in the sketch?

Paste your formatted sketch without your confidential details like token and router access.


#3

Thanks to replay.
My sketch

  /* Comment this out to disable prints and save space */
#define BLYNK_PRINT Serial


#include <SPI.h>
#include <WiFi.h>
#include <BlynkSimpleWifi.h>

// You should get Auth Token in the Blynk App.
// Go to the Project Settings (nut icon).
char auth[] = "1cfa1e**********ae7b2cc1";

// Your WiFi credentials.
// Set password to "" for open networks.
char ssid[] = "Vodafone****";
char pass[] = "aHwK******dBNY";

void setup()
{
  // Debug console
  Serial.begin(9600);

  //Blynk.begin(auth, ssid, pass);
  // You can also specify server:
  Blynk.begin(auth, ssid, pass, IPAddress(139,59,206,133), 8442);

}

void loop()
{
  Blynk.run();
}

I try both
Blynk.begin(auth, ssid, pass);
and
Blynk.begin(auth, ssid, pass, IPAddress(139,59,206,133), 8442);


#4

@Domenico_Sicignano you have a very bad system for Blynk, almost as bad as Uno with ESP-01.

Have you updated the firmware on the Uno WiFi ?

Study [Solved] Arduino.org Uno WiFi board with Firmware 1.0.0 and WiFiLink.h Librairies


#5

I just update firmaware but not change.

The shield is connected to wifi network ( ping respond), but no connected to blynk server.


#6

Did you make all the changes covered in the link I provided?


#7

I am not sure about how do:

Have I modify the BlynkSimpleWifi.h file in library?


#8

Read the whole thread a few times and then concentrate on the posts from [Solved] Arduino.org Uno WiFi board with Firmware 1.0.0 and WiFiLink.h Librairies onwards.


#9

ok thanks. But Did you experimented the same problem in the past?


#10

No I wouldn’t be seen dead with that hardware setup, $3 to $5 plug and play ESP8266 boards for me.


#11

LOL :slight_smile: