BLYNK
BLYNK.IO       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Blynk local server not working

Hi. I have recently tried to start a local server in my laptop. I successfully downloaded and can start the local server. This is what my CMD shows-

So when I try to connect to this server from my phone, it says that “app could not initialize connection to the server”. I had typed in my laptop’s IP address and 8440 as the port.
I was trying to make a new account and then it gives me the above error.
What do I do?
Thanks a lot in advance!

This is my blynk.log file-
16:57:57.411 INFO - Using data dir ‘server_data’
16:57:57.440 INFO - Region : local. Host : 192.168.86.55.
16:57:57.780 INFO - Initializing gmail smtp mail transport. Username : example@gmail.com. SMTP host : smtp.gmail.com:587
16:57:57.910 INFO - Reports : 0
16:57:57.910 INFO - Didn’t find custom user certificates.
16:57:57.911 INFO - Didn’t find Let’s Encrypt certificates.
16:57:57.911 WARN - You didn’t specified ‘server.host’ or ‘contact.email’ properties in server.properties file. Automatic certificate generation is turned off. Please specify above properties for automatic certificates retrieval.
16:57:57.911 WARN - ATTENTION. Server certificate paths (cert : ‘C:\Users\harsh\Downloads’, key : ‘C:\Users\harsh\Downloads’) not valid. Using embedded server certs and one way ssl. This is not secure. Please replace it with your own certs.
16:57:58.506 INFO - HTTP API and WebSockets server listening at 8080 port.
16:57:58.508 INFO - HTTPS API, WebSockets and Admin page server listening at 9443 port.
16:57:58.509 INFO - Mqtt hardware server listening at 8440 port.

I had also tried to use 9443 as my port but it gives me the same error.
I am also able to access the web url too

Try this

https://192.168.86.55:9443/admin#

Yeah, the web url is working but the app isn’t.

You’re using the wrong port in your app custom settings, it should be 9443

Pete.

1 Like

I tried it with 9443 too and it also isn’t working. Its giving me the same error.

Is your mobile phone connected to the same network via WiFi?

What EXACTLY are you putting in your custom server settings?

Can you ping your server from your phone and vice-versa?

Pete.

Yes, they are connected to the same network.
I put in 192.168.86.55 as the ip and 9443 as the port.
I don’t exactly get what you are asking but when I put in those credentials, it says that “app could not initialize connection to the server”. I even tried with an emulator but even that didn’t work. But when i try to access the IP via Chrome, it shows me the login page and connected devices, etc.

If you don’t understand what pinging is then I’d suggest that you google it.

Have you tried disabling the firewall on your laptop?

Pete.

Il ne faut pas autoriser dans google security, les application tierce ?

Have you setup the email section on your local server?
If yes Create a new account from your phone and have it send via email your new Auth Token.
If no Create a new account from your phone and then Log into the Admin section using Chrome and select the new user you just created. If you scroll down on the user info page you will see your new Auth Token Select and copy. Go to next step below.

Add this new Auth Token to your sketch and upload it to your device.
Now try to connect to the new Blynk user with your phone.

I have similar problem. I have succesfull ping my server i can log in blynk account and add buttom and other. But i can’t send my auth key and when i upload the code in the esp ,(after change in code the link port and ip server) after uploading , i can control because is disconnected( warning red n top corner right)

To be able to do that you need to have correctly configured your mail.properties file (and the restarted the Blynk server).
However, you can copy the auth token in the app and paste it into an email, WhatsApp message etc etc and send it from your phone to your PC. You can also log into the admin console and view/copy the auth token from there.

Change it to what?

What does your serial monitor show?

Pete.

Have already set mail.propreties succesfull. I can take auth code and put in my code i change the blynk(auth,ssid,pass) as write be default to my own info blynk(auth,ssid,pass(192.168.3.150),9443)

And in serail the output are:
Show the version of blynk and after it try alway to connect to 192.168.3.150 and nothing after (it alway try to reconnect non stop always unssuccefully

I have change the security of app account too. Is always say (when i try to send auth key or connect in blynk app) unable to connect to send e.ail. please check internet connection.

I have message too in app
Sorry server can’t talk now, try later

How have you proven that this is working correctly?
Are you signing-in to the app with your own email address?

That’s not the correct syntax, and you should probably be using port 8080

And what version is that?
You should be using 0.6.1

Pete.

Yes 0.6.1 but for the port it only work login or create new account only work with 9443 , i have try 8080 8440 too only 9443 have worker o retry it just for the luck

Write , cant connect to server retry later, and with 9443 port it create or login succefull

In my code it is exactly write like that : Blynk.begin (auth,ssid,pass,IPAddress(192.168.3.150),9443);

The IPAddress variable type expects commas between the address octets, not decimal points.

Port 9443 is the port used by the app to communicate with the server and for the admin console.
It is also used by the devices when using SSL connections.

To get started, you should be using port 8080 in the Blynk.begin command, and the Blynk “simple” libraries.

Pete.